summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-12-24 16:53:32 +0100
committerSam James <sam@gentoo.org>2024-12-25 01:46:41 +0000
commit3c9ddf9a2dbd9781823c5f292641a1a9be3fd930 (patch)
treea90a1fb3eeeab99f2f01714f61e77c732915c993 /net-analyzer
parentnet-analyzer/nfdump: fix compilation for >=sys-devel/gcc-14 + >=net-analyzer/... (diff)
downloadgentoo-3c9ddf9a2dbd9781823c5f292641a1a9be3fd930.tar.gz
gentoo-3c9ddf9a2dbd9781823c5f292641a1a9be3fd930.tar.bz2
gentoo-3c9ddf9a2dbd9781823c5f292641a1a9be3fd930.zip
net-analyzer/nfdump: add 1.7.5
Closes: https://bugs.gentoo.org/943205 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/39840 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nfdump/Manifest1
-rw-r--r--net-analyzer/nfdump/nfdump-1.7.5.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-analyzer/nfdump/Manifest b/net-analyzer/nfdump/Manifest
index c29eee945827..74213c7e571c 100644
--- a/net-analyzer/nfdump/Manifest
+++ b/net-analyzer/nfdump/Manifest
@@ -1,2 +1,3 @@
DIST nfdump-1.7.2.tar.gz 697405 BLAKE2B cf52f2cca5d80070bc00c7a7a87cc4820f04904ddeeebd4fc93cf3a2433bcf5798191daa86f0bfc7ee1f2f92e5d8bb087114d2c17e32b641a224189aeb54f822 SHA512 858d0aaae24f2e38f3708db9fd5cd40e99a6a50d5da5738c8ce4bf898fb153ce439c504d5fe8fb3c296d0069511a6f229ebdfc117f849a482e5ffdf457f06003
DIST nfdump-1.7.4.tar.gz 756319 BLAKE2B 441fb5d3fcb4b83bfc42861eac67bf96ac7c7d6a44afd47c4e16615b22261e1628a1bffc645071817eb9085857ca3a3b632fd265dc897cf9af8fce2999f86787 SHA512 be65aeee9b982b30633102b3ca0f84eab280ca4fda4544be458a2387d051e62517127a2625bbc4329a844550a613df67f5015cc5a90a8e4b6a8c65d045650ee2
+DIST nfdump-1.7.5.tar.gz 835261 BLAKE2B 60b92395c7c3ccdd7b7d5a1b05bc2b69aeef872a40eb32cad76b99f6fd9e5960c1433812063ee7135f23f13031d5cde08ed60918bbb8688448515eabc97fc79e SHA512 80223a5bb28ccedd955bee94771284e845bbd76520cefb70f7c87bad2fb209885ae170fc710f03edabe06c61f4776c3789493358187cb3273bd4217ebcbbe1dd
diff --git a/net-analyzer/nfdump/nfdump-1.7.5.ebuild b/net-analyzer/nfdump/nfdump-1.7.5.ebuild
new file mode 100644
index 000000000000..547fac45f4ec
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.7.5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs systemd
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="https://github.com/phaag/nfdump"
+SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jnat ftconv nfpcapd nfprofile nftrack nsel readpcap sflow zstd"
+
+REQUIRED_USE="?? ( jnat nsel )"
+
+RDEPEND="
+ app-arch/bzip2
+ app-arch/lz4:=
+ sys-libs/zlib
+ elibc_musl? ( sys-libs/fts-standalone )
+ ftconv? ( net-analyzer/flow-tools )
+ nfpcapd? ( net-libs/libpcap )
+ nfprofile? ( net-analyzer/rrdtool )
+ nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+ doc? (
+ app-text/doxygen
+ media-gfx/graphviz
+ )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Not available on Linux, with fallback at src/libnffile/util.h, bug #904952
+ htonll
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.19-libft.patch
+)
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use doc; then
+ doxygen -u doc/Doxyfile.in || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ # bug #853763
+ use elibc_musl && append-libs "-lfts"
+
+ # --without-ftconf is not handled well, bug #322201
+ local myeconfargs=(
+ $(usex ftconv "--enable-ftconv --with-ftpath=${EPREFIX}/usr")
+ $(usex nfpcapd --enable-nfpcapd)
+ $(usex nfprofile --enable-nfprofile)
+ $(usex nftrack --enable-nftrack)
+ $(use_enable debug devel)
+ $(use_enable jnat)
+ $(use_enable nsel)
+ $(use_enable readpcap)
+ $(use_enable sflow)
+ $(use_with zstd "zstdpath" "${EPREFIX}/usr")
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test(){
+ pushd src/test || die
+ emake -j1 check-TESTS
+ popd || die
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+
+ newinitd "${FILESDIR}"/nfcapd.initd nfcapd
+ newconfd "${FILESDIR}"/nfcapd.confd nfcapd
+ systemd_newunit "${FILESDIR}/nfdump.service" nfdump@.service
+
+ if use doc; then
+ dodoc -r doc/html
+ fi
+}