summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-12-07 19:23:23 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-12-21 10:04:02 +0100
commitad92771a1c0764f5b850216183e0b3bbf012d5bb (patch)
tree0953924b21541fefe7b97a24d66ff485bd179a73 /net-analyzer
parentnet-analyzer/gvm-tools: add 24.12.1, drop 24.3.0 (diff)
downloadgentoo-ad92771a1c0764f5b850216183e0b3bbf012d5bb.tar.gz
gentoo-ad92771a1c0764f5b850216183e0b3bbf012d5bb.tar.bz2
gentoo-ad92771a1c0764f5b850216183e0b3bbf012d5bb.zip
net-analyzer/notus-scanner: add 22.6.5
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39623 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/notus-scanner/Manifest1
-rw-r--r--net-analyzer/notus-scanner/notus-scanner-22.6.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-analyzer/notus-scanner/Manifest b/net-analyzer/notus-scanner/Manifest
index a04fb86faddd..69afff5383bb 100644
--- a/net-analyzer/notus-scanner/Manifest
+++ b/net-analyzer/notus-scanner/Manifest
@@ -1,2 +1,3 @@
DIST notus-scanner-22.6.3.tar.gz 293997 BLAKE2B 889416d2324088dc11f2df5146b3c88b276d1170552f55b2cb7ef49f4d8d855b98d6c0e53a1d49bd725b97b88c12df69a1997a38a614aa941dd699d0efb1de51 SHA512 fc3a05a3a9d61dd0b7a9913cfbbf507fec9dd3797a42a82283d14ab7fa8090fbc847487cf3a1d064f49572dda9acadba4bd7d30003fd32a179f572e327254546
DIST notus-scanner-22.6.4.tar.gz 293607 BLAKE2B 75bdbd9d6247a2b9afaf7b049b8b80b2a44714ad4d6c951c9d14898c8bce319c39c4a19162fe1a380ef638164f025c210346ee5659ed1caefdb91bef2a0906d7 SHA512 5a3f23425a1945636c6fd9dd7b3ad39cf6f02920c33aaa35e3aa7ae1dfb8962d60f8e8519047e631c0e72a1a75c56ac5350c9dd291c20947fac2d4cdbb7f6387
+DIST notus-scanner-22.6.5.tar.gz 294136 BLAKE2B 6dcf2b79e359578dde89fb7e12d135df48a4f76d4ca2ae7f5404c2a77938a8f2593db53ee13aac7ca9927b7812994de85b076e78f0eaa451a7868bbe0e23c511 SHA512 6dd8deee45a80c07e51e29a1e64953c359c832b2b8103ab6aab8bb0fe36c78f07c7d2841417305088d82585ca46b3e2eada1ad08c0032069fd779f8546e02cb8
diff --git a/net-analyzer/notus-scanner/notus-scanner-22.6.5.ebuild b/net-analyzer/notus-scanner/notus-scanner-22.6.5.ebuild
new file mode 100644
index 000000000000..d107404140b9
--- /dev/null
+++ b/net-analyzer/notus-scanner/notus-scanner-22.6.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 greadme systemd
+
+DESCRIPTION="Notus is a vulnerability scanner for creating results from local security checks"
+HOMEPAGE="https://github.com/greenbone/notus-scanner"
+SRC_URI="https://github.com/greenbone/notus-scanner/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3 AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ acct-user/gvm
+ net-libs/paho-mqtt-c
+ >=dev-python/psutil-6.1[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.5.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/paho-mqtt-1.5.1[${PYTHON_USEDEP}]
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-misc/mosquitto
+"
+
+PATCHES=(
+ "${FILESDIR}"/notus-scanner-22.6.2-remove-tests.patch
+)
+
+GREADME_DISABLE_AUTOFORMAT=1
+
+distutils_enable_tests unittest
+
+python_install() {
+ distutils-r1_python_install
+
+ insinto /etc/gvm
+ newins "${FILESDIR}/${PN}.toml" "${PN}.toml"
+
+ # Set proper permissions on required files/directories
+ keepdir /var/lib/notus
+ keepdir /var/lib/notus/products
+ keepdir /var/lib/notus/advisories
+ keepdir /var/log/gvm
+ if ! use prefix; then
+ fowners -R gvm:gvm /etc/gvm
+ fowners -R gvm:gvm /var/lib/notus
+ fowners -R gvm:gvm /var/log/gvm
+ fi
+
+ # Adding notus-scanner.log to logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" "${PN}"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+
+ systemd_dounit config/${PN}.service
+
+ systemd_install_serviced "${FILESDIR}/notus-scanner.service.conf" \
+ ${PN}.service
+
+ greadme_stdin <<-EOF
+For validating the feed content, a GnuPG keychain with the Greenbone Community Feed
+integrity key needs to be created. Please, read here on how to create it:
+ - https://greenbone.github.io/docs/latest/22.4/source-build/index.html#feed-validation
+ - https://wiki.gentoo.org/wiki/Greenbone_Vulnerability_Management#Notus_Scanner
+
+To enable feed validation, edit /etc/gvm/${PN}.toml and set
+ disable-hashsum-verification = false
+EOF
+}