summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-26 21:37:20 +0000
committerSam James <sam@gentoo.org>2022-03-26 21:37:51 +0000
commitbbd323c44e6eb0de78cbed3106cf0adb7fdeaecd (patch)
tree87bb3cb540656f4fa16b235d5bb91435c4ea842e /net-analyzer
parentapp-editors/emacs: Backport WebKit sandboxing patch to slot 26 (diff)
downloadgentoo-bbd323c44e6eb0de78cbed3106cf0adb7fdeaecd.tar.gz
gentoo-bbd323c44e6eb0de78cbed3106cf0adb7fdeaecd.tar.bz2
gentoo-bbd323c44e6eb0de78cbed3106cf0adb7fdeaecd.zip
net-analyzer/wireshark: fix paths in live ebuild
Closes: https://bugs.gentoo.org/835860 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-3.6.3.ebuild12
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild19
2 files changed, 7 insertions, 24 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.6.3.ebuild b/net-analyzer/wireshark/wireshark-3.6.3.ebuild
index 7d40549271cb..76a4a4ef4420 100644
--- a/net-analyzer/wireshark/wireshark-3.6.3.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.6.3.ebuild
@@ -6,7 +6,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..2} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg-utils cmake
+inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg cmake
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -248,9 +248,7 @@ src_install() {
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
+ xdg_pkg_postinst
# Add group for users allowed to sniff.
chgrp pcap "${EROOT}"/usr/bin/dumpcap
@@ -265,9 +263,3 @@ pkg_postinst() {
ewarn "add yourself to the pcap group. This security measure ensures"
ewarn "that only trusted users are allowed to sniff your traffic."
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 7d40549271cb..3c9c26865ea3 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..2} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg-utils cmake
+inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg cmake
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -207,8 +207,7 @@ src_install() {
# install headers
insinto /usr/include/wireshark
- doins ws_diag_control.h ws_symbol_export.h \
- "${BUILD_DIR}"/config.h
+ doins "${BUILD_DIR}"/config.h
# If trying to remove this, try build e.g. libvirt first!
# At last check, Fedora is still doing this too.
@@ -233,12 +232,12 @@ src_install() {
for s in 16 32 48 64 128 256 512 1024 ; do
insinto /usr/share/icons/hicolor/${s}x${s}/apps
- newins image/wsicon${s}.png wireshark.png
+ newins resources/icons/wsicon${s}.png wireshark.png
done
for s in 16 24 32 48 64 128 256 ; do
insinto /usr/share/icons/hicolor/${s}x${s}/mimetypes
- newins image/WiresharkDoc-${s}.png application-vnd.tcpdump.pcap.png
+ newins resources/icons//WiresharkDoc-${s}.png application-vnd.tcpdump.pcap.png
done
fi
@@ -248,9 +247,7 @@ src_install() {
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
+ xdg_pkg_postinst
# Add group for users allowed to sniff.
chgrp pcap "${EROOT}"/usr/bin/dumpcap
@@ -265,9 +262,3 @@ pkg_postinst() {
ewarn "add yourself to the pcap group. This security measure ensures"
ewarn "that only trusted users are allowed to sniff your traffic."
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}