summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/mwavem
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/mwavem')
-rw-r--r--net-dialup/mwavem/Manifest1
-rwxr-xr-xnet-dialup/mwavem/files/mwave-dev-handler11
-rw-r--r--net-dialup/mwavem/files/mwave.devfs2
-rw-r--r--net-dialup/mwavem/files/mwave.modules1
-rw-r--r--net-dialup/mwavem/files/mwavem-2.0-gentoo.patch24
-rw-r--r--net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch40
-rw-r--r--net-dialup/mwavem/metadata.xml6
-rw-r--r--net-dialup/mwavem/mwavem-2.0-r1.ebuild64
-rw-r--r--net-dialup/mwavem/mwavem-2.0-r2.ebuild53
9 files changed, 202 insertions, 0 deletions
diff --git a/net-dialup/mwavem/Manifest b/net-dialup/mwavem/Manifest
new file mode 100644
index 000000000000..de988bcb45de
--- /dev/null
+++ b/net-dialup/mwavem/Manifest
@@ -0,0 +1 @@
+DIST mwavem-2.0.tar.gz 1443167 SHA256 4b3da6be3ec44caee70ef041f58054ac15ddc12c95455a068ef44edf633329ee SHA512 e1bb3c7e5511abc784b0359b844498389a9cb970fe46752775aaae6146d8cf25998a6e12dfc70df5c5f4287fd57abb49252f81a00528db5f7c2c96e3e7efb516 WHIRLPOOL 4d4728ffe824ae0b9ab77ea89f047d420404dafe0fe999d1378695e5ff4cbef6464091709f6b413522477d432043e99e19cbe120191669c2d9ac98118a04241d
diff --git a/net-dialup/mwavem/files/mwave-dev-handler b/net-dialup/mwavem/files/mwave-dev-handler
new file mode 100755
index 000000000000..3ba51ff75db2
--- /dev/null
+++ b/net-dialup/mwavem/files/mwave-dev-handler
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+case "$1" in
+register)
+ [ ! -d /dev/modem ] && mkdir --mode=0755 /dev/modems
+ [ ! -h /dev/modems/mwave ] && ln -s /dev/misc/mwave /dev/modems/mwave
+ ;;
+unregister)
+ rm -rf /dev/modems/mwave
+ ;;
+esac
diff --git a/net-dialup/mwavem/files/mwave.devfs b/net-dialup/mwavem/files/mwave.devfs
new file mode 100644
index 000000000000..67ba1e527ab9
--- /dev/null
+++ b/net-dialup/mwavem/files/mwave.devfs
@@ -0,0 +1,2 @@
+REGISTER ^misc/mwave$ EXECUTE /usr/sbin/mwave-dev-handler register
+UNREGISTER ^misc/mwave$ EXECUTE /usr/sbin/mwave-dev-handler unregister
diff --git a/net-dialup/mwavem/files/mwave.modules b/net-dialup/mwavem/files/mwave.modules
new file mode 100644
index 000000000000..613eef5c77a1
--- /dev/null
+++ b/net-dialup/mwavem/files/mwave.modules
@@ -0,0 +1 @@
+alias char-major-10-219 mwave
diff --git a/net-dialup/mwavem/files/mwavem-2.0-gentoo.patch b/net-dialup/mwavem/files/mwavem-2.0-gentoo.patch
new file mode 100644
index 000000000000..ca86b5039444
--- /dev/null
+++ b/net-dialup/mwavem/files/mwavem-2.0-gentoo.patch
@@ -0,0 +1,24 @@
+diff -ur mwavem-2.0.orig/configure.in mwavem-2.0/configure.in
+--- mwavem-2.0.orig/configure.in 2004-04-06 23:50:57.000000000 +0000
++++ mwavem-2.0/configure.in 2008-10-18 09:31:29.000000000 +0000
+@@ -27,7 +27,7 @@
+ AC_DEFINE(MWWTDBG)
+
+ INCLUDES="-I\$(top_srcdir)/src/include"
+-CFLAGS="$INCLUDES -O2 -fno-strict-aliasing -fomit-frame-pointer -Wall"
++CFLAGS="${CFLAGS} $INCLUDES -fno-strict-aliasing -Wall"
+
+ dnl Set dsp_dir here and we substitute it in mwavem.conf from mwavem.conf.in
+ dsp_dir=` test "x$exec_prefix" = xNONE && exec_prefix=$ac_default_prefix
+diff -ur mwavem-2.0.orig/src/mwavem/Makefile.am mwavem-2.0/src/mwavem/Makefile.am
+--- mwavem-2.0.orig/src/mwavem/Makefile.am 2008-10-18 09:38:52.000000000 +0000
++++ mwavem-2.0/src/mwavem/Makefile.am 2008-10-18 09:38:00.000000000 +0000
+@@ -10,6 +10,8 @@
+ -rm $(distdir)/modem.c
+
+ install-exec-local:
++
++install-exec-local-invalid:
+ if [ ! -c "/dev/modems/mwave" ]; then \
+ mkdir -p /dev/modems; \
+ mknod --mode=660 /dev/modems/mwave c 10 219; \
diff --git a/net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch b/net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch
new file mode 100644
index 000000000000..fa867986ec22
--- /dev/null
+++ b/net-dialup/mwavem/files/mwavem-2.0-glibc-2.10.patch
@@ -0,0 +1,40 @@
+diff -ur mwavem-2.0.orig/src/include/mwmparsi.h mwavem-2.0/src/include/mwmparsi.h
+--- mwavem-2.0.orig/src/include/mwmparsi.h 2001-05-04 22:28:52.000000000 +0300
++++ mwavem-2.0/src/include/mwmparsi.h 2009-08-08 11:58:51.000000000 +0300
+@@ -516,8 +516,8 @@
+
+
+ #ifdef DEBUG
+- void dprintf(char *szFormat, ...);
+- #define DPF dprintf
++ void mwavem_dprintf(char *szFormat, ...);
++ #define DPF mwavem_dprintf
+
+ #else
+ #define DPF ((void)0)
+diff -ur mwavem-2.0.orig/src/include/mwmspcfc.h mwavem-2.0/src/include/mwmspcfc.h
+--- mwavem-2.0.orig/src/include/mwmspcfc.h 2001-05-04 22:28:52.000000000 +0300
++++ mwavem-2.0/src/include/mwmspcfc.h 2009-08-08 11:56:34.000000000 +0300
+@@ -705,8 +705,8 @@
+ void MWM_ENTRY mwmPostMessage(UINT uMsg, LONG wParam, LONG lParam); // @TBD
+
+ #ifdef DEBUG
+- void dprintf(char *szFormat, ...);
+- #define DPF dprintf
++ void mwavem_dprintf(char *szFormat, ...);
++ #define DPF mwavem_dprintf
+ #else
+ #define DPF ((void)0)
+ #endif
+diff -ur mwavem-2.0.orig/src/mwmlw32/mwmload.c mwavem-2.0/src/mwmlw32/mwmload.c
+--- mwavem-2.0.orig/src/mwmlw32/mwmload.c 2004-03-31 06:58:55.000000000 +0300
++++ mwavem-2.0/src/mwmlw32/mwmload.c 2009-08-08 11:56:50.000000000 +0300
+@@ -72,7 +72,7 @@
+
+
+ #define MODNAME "MWMODEM"
+-void dprintf(char *szFormat, ...)
++void mwavem_dprintf(char *szFormat, ...)
+ {
+ /*if (usDebugWindow)
+ {*/
diff --git a/net-dialup/mwavem/metadata.xml b/net-dialup/mwavem/metadata.xml
new file mode 100644
index 000000000000..acee6b7963aa
--- /dev/null
+++ b/net-dialup/mwavem/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+<longdescription>User level application for IBM Mwave modem.</longdescription>
+</pkgmetadata>
diff --git a/net-dialup/mwavem/mwavem-2.0-r1.ebuild b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
new file mode 100644
index 000000000000..5c6478f86ae2
--- /dev/null
+++ b/net-dialup/mwavem/mwavem-2.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+AT_M4DIR="m4"
+
+inherit autotools eutils
+
+DESCRIPTION="User level application for IBM Mwave modem"
+HOMEPAGE="http://oss.software.ibm.com/acpmodem/"
+SRC_URI="ftp://www-126.ibm.com/pub/acpmodem/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dosbin "${FILESDIR}/mwave-dev-handler"
+
+ insinto /etc/devfs.d
+ newins "${FILESDIR}/mwave.devfs" mwave
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/mwave.modules" mwave.conf
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README README.devfs THANKS
+ docinto doc
+ dodoc doc/mwave.sgml doc/mwave.txt
+ dohtml doc/mwave.html
+}
+
+pkg_postinst() {
+ # Below is to get /etc/modules.d/mwave loaded into /etc/modules.conf
+ if [ "$ROOT" = "/" ]; then
+ [ -x /sbin/update-modules ] && /sbin/update-modules || /sbin/modules-update
+ fi
+
+ if [ -e "${ROOT}/dev/.devfsd" ]; then
+ # device node is created by devfs
+ ebegin "Restarting devfsd to reread devfs rules"
+ killall -HUP devfsd
+ eend $?
+ elif [ -e "${ROOT}/dev/.udev" ]; then
+ #the device should be created by udev
+ ebegin "Restarting udev to reread udev rules"
+ udevadm control --reload-rules
+ eend $?
+ else
+ [ ! -d "${ROOT}/dev/modem" ] && mkdir --mode=0755 "${ROOT}/dev/modems"
+ mknod --mode=0660 "${ROOT}/dev/modems/mwave" c 10 219
+ fi
+}
diff --git a/net-dialup/mwavem/mwavem-2.0-r2.ebuild b/net-dialup/mwavem/mwavem-2.0-r2.ebuild
new file mode 100644
index 000000000000..180e692a38b9
--- /dev/null
+++ b/net-dialup/mwavem/mwavem-2.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AT_M4DIR="m4"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="User level application for IBM Mwave modem"
+HOMEPAGE="http://oss.software.ibm.com/acpmodem/"
+SRC_URI="ftp://www-126.ibm.com/pub/acpmodem/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README README.devfs THANKS )
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.patch"
+ "${FILESDIR}/${P}-glibc-2.10.patch"
+)
+
+src_install() {
+ autotools-utils_src_install
+
+ dosbin "${FILESDIR}/mwave-dev-handler"
+
+ insinto /etc/devfs.d
+ newins "${FILESDIR}/mwave.devfs" mwave
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/mwave.modules" mwave.conf
+
+ docinto doc
+ dodoc doc/mwave.sgml doc/mwave.txt
+ dohtml doc/mwave.html
+}
+
+pkg_postinst() {
+ if [ -e "${ROOT}/dev/.devfsd" ]; then
+ # device node is created by devfs
+ ebegin "Restarting devfsd to reread devfs rules"
+ killall -HUP devfsd
+ eend $?
+ else
+ elog "Create device node if needed, using command like this:"
+ elog "# mknod --mode=0660 \"${ROOT}/dev/modems/mwave\" c 10 219"
+ fi
+}