summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/picocom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/picocom')
-rw-r--r--net-dialup/picocom/Manifest1
-rw-r--r--net-dialup/picocom/metadata.xml11
-rw-r--r--net-dialup/picocom/picocom-1.7.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/net-dialup/picocom/Manifest b/net-dialup/picocom/Manifest
new file mode 100644
index 000000000000..df6fb7cc414a
--- /dev/null
+++ b/net-dialup/picocom/Manifest
@@ -0,0 +1 @@
+DIST picocom-1.7.tar.gz 42857 SHA256 d0f31c8f7a215a76922d30c81a52b9a2348c89e02a84935517002b3bc2c1129e SHA512 a222cc61be1e3e9759d8d6269348f6ac13159089e41b5a6aade3dc15abab8d76571a91c970f14af89244055f8bb9adf1ad5b336d7a9b4db5a9449558b86577ec WHIRLPOOL 1bb3b05e2fa111a55611e2586d93b16adeca397f368f1c6f3309f36490405afabbc9875dce262e548aa105c5f128ee004eaa7ec47772908e69689ff1ef68838f
diff --git a/net-dialup/picocom/metadata.xml b/net-dialup/picocom/metadata.xml
new file mode 100644
index 000000000000..418d529e8a68
--- /dev/null
+++ b/net-dialup/picocom/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">picocom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-dialup/picocom/picocom-1.7.ebuild b/net-dialup/picocom/picocom-1.7.ebuild
new file mode 100644
index 000000000000..1cb7da3d6d21
--- /dev/null
+++ b/net-dialup/picocom/picocom-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="http://code.google.com/p/picocom/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's:\./picocom:picocom:' pcasc || die
+}
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm}
+ doman picocom.8
+ dohtml picocom.8.html
+ dodoc CHANGES CHANGES.old CONTRIBUTORS README TODO
+}