summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 09:45:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 10:01:09 +0200
commitb0db2c017d233ffd19b58354608b0e226988c06c (patch)
tree991663e363bc45c7d4795ae9d89f8f6d2c2db299 /net-dns/dnssec-tools
parentdev-vcs/kdesvn: Fix build with Qt 5.11 (diff)
downloadgentoo-b0db2c017d233ffd19b58354608b0e226988c06c.tar.gz
gentoo-b0db2c017d233ffd19b58354608b0e226988c06c.tar.bz2
gentoo-b0db2c017d233ffd19b58354608b0e226988c06c.zip
net-dns/dnssec-tools: EAPI 6, bogus qt4-r2, drop ltprune
Bug: https://bugs.gentoo.org/645418 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'net-dns/dnssec-tools')
-rw-r--r--net-dns/dnssec-tools/dnssec-tools-2.2-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-dns/dnssec-tools/dnssec-tools-2.2-r1.ebuild b/net-dns/dnssec-tools/dnssec-tools-2.2-r1.ebuild
new file mode 100644
index 000000000000..6b83d1c27fd7
--- /dev/null
+++ b/net-dns/dnssec-tools/dnssec-tools-2.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Tools to ease the deployment of DNSSEC related technologies"
+HOMEPAGE="https://www.dnssec-tools.org/"
+SRC_URI="https://www.dnssec-tools.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Crypt-OpenSSL-Random
+ dev-perl/Getopt-GUI-Long
+ dev-perl/GraphViz
+ dev-perl/MailTools
+ dev-perl/Net-DNS
+ dev-perl/Net-DNS-SEC
+ dev-perl/XML-Simple"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0-dtinitconf.patch )
+
+src_prepare() {
+ default
+ sed -e '/^maninstall:/,+3s:$(MKPATH) $(mandir)/$(man1dir):$(MKPATH) $(DESTDIR)/$(mandir)/$(man1dir):' \
+ -i Makefile.in || die
+ sed -e 's:/usr/local/etc:/etc:g' \
+ -e 's:/usr/local:/usr:g' \
+ -i tools/donuts/donuts \
+ -i tools/etc/dnssec-tools/dnssec-tools.conf \
+ -i tools/scripts/genkrf || die
+}
+
+src_configure() {
+ econf \
+ --disable-bind-checks \
+ --without-validator \
+ --with-perl-build-args=INSTALLDIRS=vendor \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/rollerd.initd rollerd
+ newconfd "${FILESDIR}"/rollerd.confd rollerd
+ systemd_dounit "${FILESDIR}"/rollerd.service
+
+ newinitd "${FILESDIR}"/donutsd.initd donutsd
+ newconfd "${FILESDIR}"/donutsd.confd donutsd
+ systemd_dounit "${FILESDIR}"/donutsd.service
+
+ find "${ED}" -name "*.la" -delete || die
+ readme.gentoo_create_doc
+}
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Please run 'dtinitconf' in order to set up the required
+/etc/dnssec-tools/dnssec-tools.conf file
+
+DNSSEC Validator has been split into net-dns/dnssec-validator
+"