summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-04 10:16:49 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-04 10:22:18 -0400
commiteae8433d995137aa66c7a62e8f4ca81ae73108d5 (patch)
tree42b11e8bd3936e493e372366abad92aee45879fc /net-dns/rbldnsd
parentdev-lisp/sbcl: bump to 2.0.3 (diff)
downloadgentoo-eae8433d995137aa66c7a62e8f4ca81ae73108d5.tar.gz
gentoo-eae8433d995137aa66c7a62e8f4ca81ae73108d5.tar.bz2
gentoo-eae8433d995137aa66c7a62e8f4ca81ae73108d5.zip
net-dns/rbldnsd: drop the python-2.7 test suite.
The test suite for rbldnsd uses python-2.7 (only), and realistically that's not going to change any time soon. This commit drops the test suite from the ebuild so that the python team isn't blocked on me at some later point. If upstream ever migrates the test suite to python-3.x and makes a release, I can put it back easy enough. Bug: https://bugs.gentoo.org/715180 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-dns/rbldnsd')
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild (renamed from net-dns/rbldnsd/rbldnsd-0.998b-r1.ebuild)28
1 files changed, 6 insertions, 22 deletions
diff --git a/net-dns/rbldnsd/rbldnsd-0.998b-r1.ebuild b/net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild
index c73e294de9e9..a95bcde36f78 100644
--- a/net-dns/rbldnsd/rbldnsd-0.998b-r1.ebuild
+++ b/net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-inherit toolchain-funcs python-any-r1
+inherit toolchain-funcs
DESCRIPTION="DNS server designed to serve blacklist zones"
HOMEPAGE="https://rbldnsd.io/"
@@ -13,23 +12,18 @@ SRC_URI="https://github.com/spamhaus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~sparc ~x86"
-IUSE="ipv6 test zlib"
-RESTRICT="!test? ( test )"
+IUSE="ipv6 zlib"
RDEPEND="zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}"
BDEPEND="
acct-group/rbldns
acct-user/rbldns
- test? (
- ${RDEPEND}
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]')
- )"
+"
-PATCHES=(
- "${FILESDIR}/rbldnsd-0.997a-robust-ipv6-test-support.patch"
-)
+# The test suite was dropped from the ebuild because it requires
+# python-2.7, and it will crash if you try to run it now.
+RESTRICT=test
src_configure() {
# The ./configure file is handwritten and doesn't support a `make
@@ -48,12 +42,6 @@ src_compile() {
RANLIB="$(tc-getRANLIB)"
}
-src_test() {
- emake check \
- CC="$(tc-getCC)" \
- PYTHON="${PYTHON}"
-}
-
src_install() {
einstalldocs
dosbin rbldnsd
@@ -63,7 +51,3 @@ src_install() {
diropts -g rbldns -o rbldns -m 0750
keepdir /var/db/rbldnsd
}
-
-python_check_deps() {
- ! use test || has_version "dev-python/pydns:2[${PYTHON_USEDEP}]"
-}