summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-03 23:15:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-03 23:23:06 +0100
commit33b83a17617e5f4c5b3240ad72169d16a5b45636 (patch)
tree1c28db8b6d841a4af769af38576338acc1786cd5 /net-dns
parentnet-dns/libidn: Take it for myself (diff)
downloadgentoo-33b83a17617e5f4c5b3240ad72169d16a5b45636.tar.gz
gentoo-33b83a17617e5f4c5b3240ad72169d16a5b45636.tar.bz2
gentoo-33b83a17617e5f4c5b3240ad72169d16a5b45636.zip
net-dns/libidn: Eliminate static libs
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/libidn/libidn-1.36.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/net-dns/libidn/libidn-1.36.ebuild b/net-dns/libidn/libidn-1.36.ebuild
index b21166f2731e..cd4dbfd65a89 100644
--- a/net-dns/libidn/libidn-1.36.ebuild
+++ b/net-dns/libidn/libidn-1.36.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/libidn/${P}.tar.gz"
LICENSE="GPL-2 GPL-3 LGPL-3 java? ( Apache-2.0 )"
SLOT="0/12"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc emacs java mono nls static-libs"
+IUSE="doc emacs java mono nls"
DOCS=( AUTHORS ChangeLog FAQ NEWS README THANKS TODO )
COMMON_DEPEND="
@@ -44,17 +44,21 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE=${S} GJDOC=javadoc \
- econf \
- $(multilib_native_use_enable java) \
- $(multilib_native_use_enable mono csharp mono) \
- $(use_enable nls) \
- $(use_enable static-libs static) \
- --disable-valgrind-tests \
- --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
- --with-packager-bug-reports="https://bugs.gentoo.org" \
- --with-packager-version="r${PR}" \
+ local -x GJDOC=javadoc
+
+ local args=(
+ $(multilib_native_use_enable java)
+ $(multilib_native_use_enable mono csharp mono)
+ $(use_enable nls)
+ --disable-static
+ --disable-valgrind-tests
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packager-bug-reports="https://bugs.gentoo.org"
+ --with-packager-version="r${PR}"
--with-packager="Gentoo"
+ )
+
+ ECONF_SOURCE=${S} econf "${args[@]}"
}
multilib_src_compile() {