summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-09 09:55:20 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-17 11:18:33 +0200
commitc7be1dfd76b42cfa83dd085ccddda4abf8e07cf8 (patch)
treed65de42ad11ebf4817035cd2f8ca63efaeb8574b /net-dns
parentnet-dns/https_dns_proxy: update live ebuild (diff)
downloadgentoo-c7be1dfd76b42cfa83dd085ccddda4abf8e07cf8.tar.gz
gentoo-c7be1dfd76b42cfa83dd085ccddda4abf8e07cf8.tar.bz2
gentoo-c7be1dfd76b42cfa83dd085ccddda4abf8e07cf8.zip
net-dns/https_dns_proxy: add snapshot ebuild
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/https_dns_proxy/Manifest1
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-dns/https_dns_proxy/Manifest b/net-dns/https_dns_proxy/Manifest
new file mode 100644
index 000000000000..50bc3e35b54d
--- /dev/null
+++ b/net-dns/https_dns_proxy/Manifest
@@ -0,0 +1 @@
+DIST https_dns_proxy-0_pre20200925.tar.gz 16270 BLAKE2B 2677f63662d030fa1b6955f819eb6cbab6916356aa06ede13c4942824ea5c9c88f93d5c53fe725989ec668b3152c8242755279752abb1ed9941b57b83d137191 SHA512 8d0bc083447eaf5973a3ed3efbd7946c62fcabca7286266d2ac445aa522a11bff41201f54e1acb49483957a7f488578cfbb7053cd0cc83ca42c4146eab4e44ca
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
new file mode 100644
index 000000000000..c7003379c001
--- /dev/null
+++ b/net-dns/https_dns_proxy/https_dns_proxy-0_pre20200925.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/aarond10/https_dns_proxy.git"
+ inherit git-r3
+else
+ MY_COMMIT="2d9285e2b94bce21c588c8160f8fac660806987a"
+ SRC_URI="https://github.com/aarond10/https_dns_proxy/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_COMMIT}"
+fi
+
+DESCRIPTION="A lightweight DNS-over-HTTPS proxy"
+HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-libs/libev
+ net-dns/c-ares
+ net-misc/curl[http2,ssl]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ dobin "${WORKDIR}/${P}_build/https_dns_proxy"
+}