summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-30 21:00:38 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-30 21:03:50 +0200
commitebd9e0b2827679e63716d0f76453e75b58ad01f0 (patch)
tree37b37249bf0d7fdff8d37f1783cf88dd2976d6d8 /net-im/rocketchat-desktop-bin
parentprofiles: Drop Qt 5.15.3 package.mask (diff)
downloadgentoo-ebd9e0b2827679e63716d0f76453e75b58ad01f0.tar.gz
gentoo-ebd9e0b2827679e63716d0f76453e75b58ad01f0.tar.bz2
gentoo-ebd9e0b2827679e63716d0f76453e75b58ad01f0.zip
net-im/rocketchat-desktop-bin: add 3.8.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 0608701c7c5f..f801d3c8b587 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.8.0.x86_64.rpm 62219204 BLAKE2B 60c6a1d46138007da82214347790d5fce2cd8e8616ec0fa1d1344f064ab58281843c6692830f8a860cfb6e4ab4f41a5b2ad3bcde928c133e694b2c4fe365d885 SHA512 68b0a1c455b7d3c68bafcf2007470d89301a17b922b61cc3d1b38485235120aeacc449157f76b1629971c4329fb12244d23fb6a0b22a77082da6e37a24b6141e
+DIST rocketchat-3.8.1-linux-x86_64.rpm 62200440 BLAKE2B 7b4957810abf2868ddc071c5c0879803803a6156c07b8b19b1f6f60235535fb881976db056d18ee046842cc4dc8c373a75e8f2d48d35a67a74b2193b27a87f22 SHA512 77f6ddc44b85e38aaefcd3662d70ada411c6380aa8e9d7c6d25f3ad1dfccc17f9544d7fdcc713e3c3c933a681cd22f7a73fda8eba4080ae2490a74251d3f0969
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.1.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.1.ebuild
new file mode 100644
index 000000000000..258071fcfef4
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}-linux-x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}