summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-07-20 09:36:01 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-07-20 09:51:44 +0200
commit60535926779c6069b8656c857d82207d1b4bf7e9 (patch)
treebb5745fa9ba694d4373de2495f956e9874938958 /net-im/sendxmpp-amm
parentnet-im/sendxmpp-amm: ensure correct scala version is used (diff)
downloadgentoo-60535926779c6069b8656c857d82207d1b4bf7e9.tar.gz
gentoo-60535926779c6069b8656c857d82207d1b4bf7e9.tar.bz2
gentoo-60535926779c6069b8656c857d82207d1b4bf7e9.zip
net-im/sendxmpp-amm: sync live
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-im/sendxmpp-amm')
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
index 782316d17024..c5dec761f9fd 100644
--- a/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
inherit git-r3
else
SRC_URI="https://github.com/flowdalic/${ORIG_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="amd64"
S="${WORKDIR}/${ORIG_PN}-${PV}"
fi
@@ -22,6 +22,21 @@ LICENSE="GPL-3+"
SLOT="0"
RDEPEND="
- dev-lang/ammonite-repl-bin
+ dev-lang/ammonite-repl-bin[scala2-13]
!net-im/sendxmpp
"
+
+src_prepare() {
+ default
+ # Ensure that the script is using the right Scala version.
+ sed -i '1 s;^.*$;#!/usr/bin/env amm-2.13;' sendxmpp.sc || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ default
+ newbin sendxmpp.sc sendxmpp
+}