summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/simpserver-bin/simpserver-bin-2.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/simpserver-bin/simpserver-bin-2.1.0.ebuild')
-rw-r--r--net-im/simpserver-bin/simpserver-bin-2.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/simpserver-bin/simpserver-bin-2.1.0.ebuild b/net-im/simpserver-bin/simpserver-bin-2.1.0.ebuild
new file mode 100644
index 000000000000..cb5179e98fe5
--- /dev/null
+++ b/net-im/simpserver-bin/simpserver-bin-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN=${PN/-bin/}
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SimpServer for Unix: IM instant security transparent proxy"
+SRC_URI="http://download.secway.com/public/products/simpserver/${MY_P}-linux-x86.tgz"
+HOMEPAGE="http://www.secway.com/"
+LICENSE="simpserver-test"
+
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+SLOT="0"
+S=${WORKDIR}/simp
+
+RESTRICT="strip"
+
+src_compile() {
+ einfo "Binary distribution. No compilation required."
+}
+
+src_install () {
+ dodoc README VERSION doc/CONFIG doc/TODO
+
+ exeinto /opt/bin
+ doexe bin/${MY_PN}
+
+ insinto /etc
+ doins etc/simp.conf
+
+ newinitd "${FILESDIR}/${MY_PN}".rc ${MY_PN}
+}
+
+pkg_postinst() {
+ elog "Please edit the configuration file: /etc/simp.conf."
+}