summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-06 18:30:33 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-06 18:37:04 +0100
commit14745f7a944e1dc2e611e781d130f03c0efb47aa (patch)
treeb5032e995a2b21c86439fde3de6bc7e7748010dc /net-im
parentdev-lang/grass: New package, 0.13.4 (diff)
downloadgentoo-14745f7a944e1dc2e611e781d130f03c0efb47aa.tar.gz
gentoo-14745f7a944e1dc2e611e781d130f03c0efb47aa.tar.bz2
gentoo-14745f7a944e1dc2e611e781d130f03c0efb47aa.zip
net-im/fractal: Bump to 10_beta
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/fractal/Manifest2
-rw-r--r--net-im/fractal/fractal-10_beta.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/net-im/fractal/Manifest b/net-im/fractal/Manifest
index f3eb072cda29..6c32dfcba8c7 100644
--- a/net-im/fractal/Manifest
+++ b/net-im/fractal/Manifest
@@ -1,3 +1,5 @@
+DIST fractal-10.beta.tar.bz2 1964153 BLAKE2B 638525c3d177c53021c63656a74a8616e725bc2f971fe2c2a4412f45c5bbd48b76d859d6a6fc50b39141409c6429bd0bc794c155bfbbab9e0f793805df285940 SHA512 286b59500c6db5c4293e5b947e0f028a9b2c689984627ac59b642cfcefb8c299a994564b1266b3fb43172298d4b53325bee971f5ab93e56a50a5c6f630654192
+DIST fractal-10_beta-crates.tar.xz 47757844 BLAKE2B 4946bd3f60b4025617281de4e418ba77bd8868163f37c66207509b475954b19362e589ed24994c089c5ccb6001a74b40c3bcf40998e92a15cf3d55eec385828a SHA512 e38110e9bcd3deac70a0a959d387f9d1fc6a0bcf94bbd4cf70520183a753ca6f4de42d0bcea00ae4f951fe7ae4982a450e01930156ec0329b12e0caaa995471c
DIST fractal-8.tar.bz2 1860423 BLAKE2B d6b0b0a8f479d7ceda4c40bd9eb677ef01abf8304ebd4ba8d15bc96557c78ec84af37fbca241feec3e85b3ef3b4ae6bc7564a40c5232830b43b03cd73e6fe9f4 SHA512 cae1e9f85fb570a075ceb88c115d5ce8169a3c38920765e46fd0f92e6c962a2377338e330d54cf3944903828db1c0c50c51ff4de2a079b34a478248485aad952
DIST fractal-8_rc-crates.tar.xz 49000316 BLAKE2B b9c68668e762563a06ba176e23b76fab23ba97e61e48c01ad18e063426fc906c20c559a0f812fa08871b916156d3374b9308390f950e3dd1fa56ab270f8d283e SHA512 8c855aae2fbddbe2c186b6e1c0ef269ab1ced6c5ea1f3e7270681d6523549569aa6ccab91cbc803b1322d5115d9c8cda0df75d8eef9db559f10834d542454723
DIST matrix-rust-sdk-92b4c2a469f507696fa9db3d6bdb000a761e2694.gh.tar.gz 2220737 BLAKE2B df740551e28e0651447dd3f3404b9e3aa2a871acaecbfb7774a5ea62c45b89b4ddfd347fa5d1975c22874e8f629a645e6fcd8d69b14de4c4e22723b47d217755 SHA512 f2f44cc3119666a7cc3382ba95b44b757ce9ef193a004aa4423ccbe51dbcafa6ecfbab6f90f2a274e88b06cd07e45c03c357877aa36e8626f67ae04c8586e328
diff --git a/net-im/fractal/fractal-10_beta.ebuild b/net-im/fractal/fractal-10_beta.ebuild
new file mode 100644
index 000000000000..acc981e707ca
--- /dev/null
+++ b/net-im/fractal/fractal-10_beta.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+RUST_MIN_VER="1.82.0"
+
+inherit cargo gnome2-utils meson
+
+MY_P=${P/_/.}
+CRATE_P=fractal-${PV}
+
+DESCRIPTION="Matrix messaging app for GNOME written in Rust"
+HOMEPAGE="
+ https://wiki.gnome.org/Apps/Fractal
+ https://gitlab.gnome.org/World/fractal/
+"
+SRC_URI="
+ https://gitlab.gnome.org/World/fractal/-/archive/${PV/_/.}/${MY_P}.tar.bz2
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD Boost-1.0 ISC
+ MIT MPL-2.0 MPL-2.0 Unicode-3.0 ZLIB
+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.76
+ >=gui-libs/gtk-4.16:4
+ >=gui-libs/libadwaita-1.6:1
+
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-bad-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+
+ >=gui-libs/gtksourceview-5.0.0:5
+ >=media-video/pipewire-0.3.0:=[gstreamer]
+ >=media-libs/libwebp-1.0.0:=
+ >=dev-libs/openssl-1.0.1:=
+ >=media-libs/libshumate-1.0.0:1.0
+ >=dev-db/sqlite-3.24.0:3
+ >=sys-apps/xdg-desktop-portal-1.14.1
+
+ >=media-libs/lcms-2.12.0:2
+ >=sys-libs/libseccomp-2.5.0:=
+
+"
+RDEPEND="
+ ${DEPEND}
+ media-libs/glycin-loaders
+ virtual/secret-service
+"
+# clang needed by bindgen
+BDEPEND="
+ llvm-core/clang
+ dev-lang/grass
+"
+
+# Rust
+QA_FLAGS_IGNORED="usr/bin/fractal"
+
+src_prepare() {
+ default
+
+ # upstream dev settings are insane
+ sed -i -e 's:profile\.dev:ignored.insanity:' Cargo.toml || die
+}
+
+src_configure() {
+ local mymesonargs=(
+ #-Ddisable-glycin-sandbox=true
+ )
+
+ meson_src_configure
+ ln -s "${CARGO_HOME}" "${BUILD_DIR}/cargo-home" || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}