summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJosiah Mullins <JoMull01@protonmail.com>2025-01-05 09:08:17 -0500
committerJimi Huotari <chiitoo@gentoo.org>2025-01-25 22:47:03 +0200
commit97a847d541b77960d202b6ae8a31017e940d7a9e (patch)
treebcbc78f1dd839bc7f543e231490def7aa994a230 /net-im
parentnet-im/toxic: Remove old version (diff)
downloadgentoo-97a847d541b77960d202b6ae8a31017e940d7a9e.tar.gz
gentoo-97a847d541b77960d202b6ae8a31017e940d7a9e.tar.bz2
gentoo-97a847d541b77960d202b6ae8a31017e940d7a9e.zip
net-im/toxic: Bump to toxic-0.16.0
The bug below is a request for this bump. Closes: https://bugs.gentoo.org/947366 Closes: https://github.com/gentoo/gentoo/pull/39792 Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/toxic/Manifest1
-rw-r--r--net-im/toxic/toxic-0.16.0.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 9685338d307b..50e4b99e5242 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1 +1,2 @@
DIST toxic-0.15.1.tar.gz 1246436 BLAKE2B 5af9d978957f0da687b53440b45cabb29da65ba894238b2b41427c3137b1cb764a9db489af9faa442c2fe057f1660e6c3a4303db434bd04b9dce87c07281b10d SHA512 8bb6eef248413b00124f39b798bdaf029f8c4a13c0faf0be8f061bd0b27369ae1b44e052efd25353e5bf59724a2b02892eb95fdad7a0f8d7540212475f8a17b6
+DIST toxic-0.16.0.tar.gz 1246725 BLAKE2B 47a1d22137de1db635e99dcff1618150aae5e98c1cea58ce944284c97ccd1c8c141d20be17a2f4a3691dc823a1fdb09ab312d643b224668c51c47dbf36c659cf SHA512 94e8c61bff56533f384367270b5b946727e7cb6a3f928b312c47578b104a881fd344af829bbf4712a79ef65526ba75c84c335ef31685e97b4a7b03b96bd642b2
diff --git a/net-im/toxic/toxic-0.16.0.ebuild b/net-im/toxic/toxic-0.16.0.ebuild
new file mode 100644
index 000000000000..a67629dbf7ae
--- /dev/null
+++ b/net-im/toxic/toxic-0.16.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="A curses-based client for Tox"
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+audio-notify debug experimental games llvm notification png python qrcode +sound +video +X"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ video? ( sound X ) "
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="dev-libs/libconfig:=
+ >=net-libs/tox-0.2.19:=
+ net-misc/curl
+ sys-kernel/linux-headers
+ sys-libs/ncurses:=
+ audio-notify? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ debug? ( llvm? ( llvm-core/llvm:* ) )
+ experimental? ( net-libs/tox[experimental] )
+ notification? ( x11-libs/libnotify )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? (
+ media-gfx/qrencode:=
+ png? ( media-libs/libpng )
+ )
+ sound? (
+ media-libs/openal
+ net-libs/tox:=[av]
+ )
+ video? (
+ media-libs/libvpx:=
+ net-libs/tox:=[av]
+ )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ #prevent man files from being compressed.
+ sed -i -e "/gzip/d" cfg/targets/install.mk || die "Unable to prevent compression of man pages."
+ #Fix incorrect linkage of pthread (may be optional)
+ sed -i -e 's/pthread/lpthread/g' Makefile || die "Unable to fix linking of pthread."
+ #Makefile sets some required CFLAGS only if CFLAGS variable is undefined,
+ #This line changes the "lazy set if absent" assignment to a "lazy set" assignment.
+ #look below in src_configure to see how CFLAGS are passed to the makefile in USER_CFLAGS
+ sed -i -e 's/?=/=/g' Makefile || die "Unable to change assignment of CFLAGS and LDFLAGS"
+ #Fix incomplete invocation of python-config
+ sed -i -e "s/--ldflags/--ldflags --embed/" cfg/checks/python.mk || die "Unable to fix python linking"
+}
+
+src_configure() {
+ if ! use audio-notify; then
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if use debug; then
+ export ENABLE_RELEASE=0
+ if use llvm; then
+ export ENABLE_ASAN=1
+ fi
+ fi
+ if use experimental; then
+ export ENABLE_TOX_EXPERIMENTAL=1
+ fi
+ if ! use games; then
+ export DISABLE_GAMES=1
+ fi
+ if ! use notification; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ if ! use png; then
+ export DISABLE_QRPNG=1
+ fi
+ if use python; then
+ export ENABLE_PYTHON=1
+ fi
+ if ! use qrcode; then
+ export DISABLE_QRCODE=1
+ fi
+ if ! use sound; then
+ export DISABLE_AV=1
+ fi
+ if ! use video; then
+ export DISABLE_VI=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ #Including strings.h fixes undefined reference to strcasecmp()
+ #Including linux/limits.h fixes undefinded reference to NAME_MAX and PATH_MAX macros
+ #Defining _GNU_SOURCE fixes undefined reference to strcasestr()
+ export USER_CFLAGS="${CFLAGS} -include strings.h -include linux/limits.h -D _GNU_SOURCE"
+ export USER_LDFLAGS="${LDFLAGS}"
+ #set install directory to /usr.
+ sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
+}
+
+src_install() {
+ default
+ if ! use audio-notify; then
+ rm -r "${ED}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ einfo "An example config file has been installed at /usr/share/toxic/toxic.conf.example"
+ einfo "Feel free to copy it to ~/.config/tox/toxic.conf and modify as desired"
+}