summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/irc-server
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/irc-server')
-rw-r--r--net-irc/irc-server/Manifest1
-rw-r--r--net-irc/irc-server/files/2.10.3_p3-gentoo.patch11
-rw-r--r--net-irc/irc-server/files/ircd.confd10
-rw-r--r--net-irc/irc-server/files/ircd.rc31
-rw-r--r--net-irc/irc-server/irc-server-2.11.1_p1-r2.ebuild103
-rw-r--r--net-irc/irc-server/metadata.xml5
6 files changed, 161 insertions, 0 deletions
diff --git a/net-irc/irc-server/Manifest b/net-irc/irc-server/Manifest
new file mode 100644
index 000000000000..8f571c64a807
--- /dev/null
+++ b/net-irc/irc-server/Manifest
@@ -0,0 +1 @@
+DIST irc2.11.1p1.tgz 770458 SHA256 29f83e82cd55f2e2f4362d95eae1da6b53dc1b7d05ff3f41be7b42e6dcbf2e1d SHA512 cc398ddd0129a044bb681504986f3d4d6f6e9b9b703495d62ec237c2e26a81250986336ae6076236eec7576eb0939ad931b45f09779e852cf69d101569c31c2c WHIRLPOOL eccdf4809446d2dbede0bb88928e2404a515684ef8e4b0870df00c892c70f49801edea93f458d301f99b351a705192799ed8716354961e5e19ab4b7e9bd6a0f5
diff --git a/net-irc/irc-server/files/2.10.3_p3-gentoo.patch b/net-irc/irc-server/files/2.10.3_p3-gentoo.patch
new file mode 100644
index 000000000000..36f558a70470
--- /dev/null
+++ b/net-irc/irc-server/files/2.10.3_p3-gentoo.patch
@@ -0,0 +1,11 @@
+diff -ur irc2.10.3p3.orig/contrib/tkserv/tkserv.c irc2.10.3p3/contrib/tkserv/tkserv.c
+--- irc2.10.3p3.orig/contrib/tkserv/tkserv.c 2001-03-09 07:55:38.000000000 -0600
++++ irc2.10.3p3/contrib/tkserv/tkserv.c 2004-06-08 00:14:33.648900488 -0500
+@@ -549,6 +549,7 @@
+ case -1:
+ sendto_user("You are not allowed to tkline \"%s\".", host); break;
+ default:
++ break;
+ }
+
+ retv = retv < 0 ? 0 : retv; /* errors do not allow authorization */
diff --git a/net-irc/irc-server/files/ircd.confd b/net-irc/irc-server/files/ircd.confd
new file mode 100644
index 000000000000..19766668e76c
--- /dev/null
+++ b/net-irc/irc-server/files/ircd.confd
@@ -0,0 +1,10 @@
+# /etc/conf.d/ircd: configuration for /etc/init.d/ircd
+
+# User account to run ircd as.
+
+#IRCD_USER="ircd"
+
+# Put any additional options for ircd here.
+# See ircd(8) for more information.
+
+#IRCD_OPTS=""
diff --git a/net-irc/irc-server/files/ircd.rc b/net-irc/irc-server/files/ircd.rc
new file mode 100644
index 000000000000..e04802308a8c
--- /dev/null
+++ b/net-irc/irc-server/files/ircd.rc
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+}
+
+IRCD_USER=${IRCD_USER:-ircd}
+
+checkconfig() {
+ if [ ! -e /etc/ircd/ircd.conf ] ; then
+ eerror "You need to create /etc/ircd/ircd.conf first."
+ eerror "An example can be found in /etc/ircd/ircd.conf.example"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return $?
+ ebegin "Starting ircd"
+ start-stop-daemon --start --quiet --chuid "${IRCD_USER}" --exec /usr/sbin/ircd -- ${IRCD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ircd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/ircd/ircd.pid
+ eend $?
+}
diff --git a/net-irc/irc-server/irc-server-2.11.1_p1-r2.ebuild b/net-irc/irc-server/irc-server-2.11.1_p1-r2.ebuild
new file mode 100644
index 000000000000..9ca7cf4070a6
--- /dev/null
+++ b/net-irc/irc-server/irc-server-2.11.1_p1-r2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator flag-o-matic user
+
+MY_P=irc${PV/_/}
+
+DESCRIPTION="RFC compliant IRC server"
+HOMEPAGE="http://www.irc.org/"
+SRC_URI="ftp://ftp.irc.org/irc/server/${MY_P}.tgz
+ ftp://ftp.irc.org/irc/server/Old/irc$(get_version_component_range 1-2)/${MY_P}.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="zlib ipv6"
+
+RDEPEND="sys-libs/ncurses
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-apps/grep"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup ircd
+ enewuser ircd -1 -1 -1 ircd
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/2.10.3_p3-gentoo.patch
+}
+
+src_compile () {
+ sed -i \
+ -e "s/^#undef\tOPER_KILL$/#define\tOPER_KILL/" \
+ -e "s/^#undef\tOPER_RESTART$/#define\tOPER_RESTART/" \
+ -e "s/^#undef TIMEDKLINES$/#define\tTIMEDKLINES\t60/" \
+ -e "s/^#undef\tR_LINES$/#define\tR_LINES/" \
+ -e "s/^#undef\tCRYPT_OPER_PASSWORD$/#define\tCRYPT_OPER_PASSWORD/" \
+ -e "s/^#undef\tCRYPT_LINK_PASSWORD$/#define\tCRYPT_LINK_PASSWORD/" \
+ -e "s/^#undef\tIRC_UID$/#define\tIRC_UID\t$IRCUID/" \
+ -e "s/^#undef\tIRC_GID$/#define\tIRC_GID\t$IRCGID/" \
+ -e "s/^#undef USE_SERVICES$/#define\tUSE_SERVICES/" \
+ "${S}"/support/config.h.dist
+
+ use zlib && sed -i -e "s/^#undef\tZIP_LINKS$/#define\tZIP_LINKS/" "${S}"/support/config.h.dist
+
+ econf \
+ --sysconfdir=/etc/ircd \
+ --localstatedir=/var/run/ircd \
+ --with-logdir=/var/log/ircd \
+ --with-rundir=/var/run/ircd \
+ --mandir='${prefix}/share/man' \
+ $(use_with zlib) \
+ $(use_enable ipv6 ip6) \
+ || die "econf failed"
+
+ cd $(support/config.guess)
+ emake ircd iauth chkconf ircd-mkpasswd ircdwatch tkserv || die "emake failed"
+}
+
+src_install() {
+ cd $(support/config.guess)
+
+ emake \
+ prefix=${D}/usr \
+ ircd_conf_dir=${D}/etc/ircd \
+ ircd_var_dir=${D}/var/run/ircd \
+ ircd_log_dir=${D}/var/log/ircd \
+ install-server \
+ install-tkserv \
+ || die "make install failed"
+
+ fowners ircd:ircd /var/run/ircd
+ fowners ircd:ircd /var/log/ircd
+
+ cd ../doc
+ dodoc \
+ *-New alt-irc-faq Authors BUGS ChangeLog Etiquette \
+ iauth-internals.txt INSTALL.appendix INSTALL.* LICENSE \
+ m4macros README RELEASE* rfc* SERVICE*
+
+ docinto Juped
+ dodoc Juped/Advertisement Juped/ChangeLog.* Juped/INSTALL
+
+ docinto Juped/US-Admin
+ dodoc Juped/US-Admin/Networking
+
+ docinto Nets
+ dodoc Nets/IRCNet
+
+ docinto Nets/Europe
+ dodoc Nets/Europe/*
+
+ newinitd "${FILESDIR}"/ircd.rc ircd
+ newconfd "${FILESDIR}"/ircd.confd ircd
+}
diff --git a/net-irc/irc-server/metadata.xml b/net-irc/irc-server/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/irc-server/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>