summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-20 21:20:46 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-20 21:25:04 +0000
commit6c7badd7786ba4a87ea407be061329bfd7904f8b (patch)
tree436e48ebf05503be7faa78988a6f98c2ce339d4b /net-irc/weechat/weechat-9999.ebuild
parentx11-plugins/wmmaiload: multiple build fixes (diff)
downloadgentoo-6c7badd7786ba4a87ea407be061329bfd7904f8b.tar.gz
gentoo-6c7badd7786ba4a87ea407be061329bfd7904f8b.tar.bz2
gentoo-6c7badd7786ba4a87ea407be061329bfd7904f8b.zip
net-irc/weechat: migrate to lua-single.eclass
Both the latest release and the live ebuild. Upstream build scripts use pkg-config to find Lua so there is no need to pass Lua version to cmake + it might support LuaJIT. On the other hand, they only fall back to unversioned module name having enumerated supported versions so some patching is still necessary. Both migrated ebuilds build, test and install fine for all supported Lua implementations. Closes: https://bugs.gentoo.org/752813 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index b33c433ae6d2..9612d0567f73 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -3,9 +3,10 @@
EAPI=7
+LUA_COMPAT=( lua5-{1..4} )
PYTHON_COMPAT=( python3_{7..9} )
-inherit cmake python-single-r1 xdg-utils
+inherit cmake lua-single python-single-r1 xdg-utils
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -29,6 +30,7 @@ LANGS=" cs de es fr it ja pl ru"
IUSE="doc man nls test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
test? ( nls )
"
@@ -41,7 +43,7 @@ RDEPEND="
net-misc/curl[ssl]
charset? ( virtual/libiconv )
guile? ( >=dev-scheme/guile-2.0 )
- lua? ( dev-lang/lua:0 )
+ lua? ( ${LUA_DEPS} )
nls? ( virtual/libintl )
perl? ( dev-lang/perl:= )
php? ( >=dev-lang/php-7.0:*[embed] )
@@ -62,11 +64,16 @@ BDEPEND="
nls? ( >=sys-devel/gettext-0.15 )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0-cmake_lua_version.patch
+)
+
DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
RESTRICT="!test? ( test )"
pkg_setup() {
+ use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
}