summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-31 00:06:50 -0400
committerTim Harder <radhermit@gentoo.org>2016-03-31 00:11:33 -0400
commitdf259a18b9224191c6c409c7027d265469e9812c (patch)
treec0374d4489ef781183cc2512a3aa004fa1883fbb /net-irc/weechat/weechat-9999.ebuild
parentwww-servers/nginx: version bump to 1.9.13 (diff)
downloadgentoo-df259a18b9224191c6c409c7027d265469e9812c.tar.gz
gentoo-df259a18b9224191c6c409c7027d265469e9812c.tar.bz2
gentoo-df259a18b9224191c6c409c7027d265469e9812c.zip
net-irc/weechat: respect PYTHON_SINGLE_TARGET setting
Previously it would only build against python2.7. Patch thanks to Oleg in bug #577638.
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index da163740534f..2c9d55e5b29e 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -107,7 +107,6 @@ src_configure() {
"-DENABLE_DEMO=OFF"
"-DENABLE_GTK=OFF"
"-DENABLE_JAVASCRIPT=OFF"
- "-DPYTHON_EXECUTABLE=${PYTHON}"
$(cmake-utils_use_enable alias)
$(cmake-utils_use_enable doc)
$(cmake-utils_use_enable charset)
@@ -131,7 +130,14 @@ src_configure() {
$(cmake-utils_use_enable trigger)
$(cmake-utils_use_enable xfer)
)
- [[ ${EPYTHON} == python3* ]] && mycmakeargs+=( $(cmake-utils_use_enable python PYTHON3) )
+
+ if use python; then
+ python_export PYTHON_LIBPATH
+ mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_LIBRARY="${PYTHON_LIBPATH}"
+ )
+ fi
cmake-utils_src_configure
}