summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2018-01-15 09:25:14 -0500
committerMichael Orlitzky <mjo@gentoo.org>2018-01-15 09:25:14 -0500
commit708920608956b5d497822f73fd76a0ea1c8e728a (patch)
treeca69aa007bdf57f11893d32a61a9033cfe6a8d77 /net-irc
parentdev-db/etcd: Remove old (diff)
downloadgentoo-708920608956b5d497822f73fd76a0ea1c8e728a.tar.gz
gentoo-708920608956b5d497822f73fd76a0ea1c8e728a.tar.bz2
gentoo-708920608956b5d497822f73fd76a0ea1c8e728a.zip
net-irc/shadowircd: drop unused shadowircd-6.3.3.ebuild.
Closes: https://bugs.gentoo.org/626046 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/shadowircd/files/shadowircd.initd38
-rw-r--r--net-irc/shadowircd/shadowircd-6.3.3.ebuild91
2 files changed, 0 insertions, 129 deletions
diff --git a/net-irc/shadowircd/files/shadowircd.initd b/net-irc/shadowircd/files/shadowircd.initd
deleted file mode 100644
index 5b01c2366de7..000000000000
--- a/net-irc/shadowircd/files/shadowircd.initd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-extra_started_commands="reload"
-
-depend() {
- use dns net
- provide ircd
-}
-
-start() {
- if ! [ -d /var/run/shadowircd ]; then
- ebegin "Creating /var/run/shadowircd for ${SVCNAME}"
- mkdir /var/run/shadowircd \
- && chown :shadowircd /var/run/shadowircd \
- && chmod 770 /var/run/shadowircd
- eend $?
- fi
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --exec /usr/bin/shadowircd-ircd \
- --user shadowircd --pidfile /var/run/shadowircd/ircd.pid \
- ${SHADOWIRCD_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --pidfile /var/run/shadowircd/ircd.pid
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- start-stop-daemon --signal HUP --pidfile /var/run/shadowircd/ircd.pid
- eend $?
-}
diff --git a/net-irc/shadowircd/shadowircd-6.3.3.ebuild b/net-irc/shadowircd/shadowircd-6.3.3.ebuild
deleted file mode 100644
index 422e14379dd0..000000000000
--- a/net-irc/shadowircd/shadowircd-6.3.3.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib user
-
-DESCRIPTION="An IRCd based on charybdis that adds several useful features"
-HOMEPAGE="http://shadowircd.net"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug +ipv6 largenet ssl zlib"
-
-RDEPEND="ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/yacc
- sys-devel/flex"
-
-S="${WORKDIR}/${PN}-${P}"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 "${EPREFIX}"/usr ${PN}
-}
-
-src_prepare() {
- # Fill the example configuration file with proper paths.
- sed -i \
- -e "s:path =.*modules:path = \"$(get_libdir)/${PN}/modules:g" \
- -e "s:etc/:../etc/${PN}/:g" \
- -e "s:logs/:../var/log/shadowircd/:g" \
- -e "s:test\.\(cert\|key\):ssl.\1:g" \
- doc/example.conf \
- doc/reference.conf \
- || die
-}
-
-src_configure() {
- econf \
- ac_cv_prog_cc_g=no \
- --disable-gnutls \
- $(use_enable debug assert soft) \
- $(use_enable debug iodebug) \
- $(use_enable ipv6) \
- $(use_enable !largenet small-net) \
- $(use_enable ssl openssl) \
- $(use_enable zlib) \
- --with-program-prefix=shadowircd- \
- \
- --enable-fhs-paths \
- --sysconfdir="${EPREFIX}"/etc/${PN} \
- --libdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN} \
- --with-logdir="${EPREFIX}"/var/log/${PN} \
- --with-moduledir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
- --with-rundir="${EPREFIX}"/var/run
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- insinto etc/${PN}
- newins doc/reference.conf ircd.conf
-
- keepdir var/{lib,log}/${PN}
-
- # Ensure that if `make install' created /var/run/${PN}, we still
- # force the initscript to create that directory.
- rm -rf "${D}"/var/run || die
-
- # shadowircd needs writing to its state (bandb) and log directories
- fowners :shadowircd /var/{lib,log}/${PN}
- fperms 770 /var/{lib,log}/${PN}
-
- # ensure that shadowircd can access but not modify its configuration
- # while protecting it from others
- fowners :shadowircd /etc/${PN}{,/ircd.conf}
- fperms 750 /etc/${PN}
- fperms 640 /etc/${PN}/ircd.conf
-}
-
-pkg_postinst() {
- elog "All of the shadowircd binaries in PATH have been prefixed with"
- elog "'shadowircd-' to prevent file collisions."
-}