summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-10 12:43:45 +0100
committerSam James <sam@gentoo.org>2023-05-10 12:44:14 +0100
commit51cf016382a9b77926ee2a8038b1ecb8dc168d59 (patch)
tree8b6a5d6e0e9406d44d5c2e36b4a32fd5900bc58b /net-libs/libiscsi
parentkde-plasma/libkscreen: drop 5.27.4-r2 (diff)
downloadgentoo-51cf016382a9b77926ee2a8038b1ecb8dc168d59.tar.gz
gentoo-51cf016382a9b77926ee2a8038b1ecb8dc168d59.tar.bz2
gentoo-51cf016382a9b77926ee2a8038b1ecb8dc168d59.zip
net-libs/libiscsi: add 1.19.0_p20230208 (w/ fixed tests!)
Fixes tests and compile failures. Fedora is shipping a snapshot too. Bug: https://bugs.gentoo.org/786987 Closes: https://bugs.gentoo.org/785433 Closes: https://bugs.gentoo.org/815322 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libiscsi')
-rw-r--r--net-libs/libiscsi/Manifest1
-rw-r--r--net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch24
-rw-r--r--net-libs/libiscsi/libiscsi-1.19.0_p20230208.ebuild66
-rw-r--r--net-libs/libiscsi/libiscsi-9999.ebuild18
4 files changed, 106 insertions, 3 deletions
diff --git a/net-libs/libiscsi/Manifest b/net-libs/libiscsi/Manifest
index 62c299d99f66..4973396f00fe 100644
--- a/net-libs/libiscsi/Manifest
+++ b/net-libs/libiscsi/Manifest
@@ -1,3 +1,4 @@
DIST libiscsi-1.18.0.tar.gz 271603 BLAKE2B 9e059d57ce231ba1699927c54ee7d7bda69274c6361fc0870e8a46eb032d46a5029080eab8061f2e1d06b41f0e98606aeb2444d3deb6da2a188dd6882196512c SHA512 9869fd86f8ba237d71256b16d0f94ef69fb67fac315bb7a596c4d8d6ed3abba710edf9b5f5a27f5777f7b5d2feb33c09764c27a4e6c56e38dd2566836cffe36e
DIST libiscsi-1.19.0-remove-ld-iscsi.patch.bz2 6104 BLAKE2B 611202ca0ec046caf5cbd1adaeafb42a7d7d00fcea51e61df6c251576ea276cfe9a2168a9c3f1d4c7aa585d7ff9e90a95d8da03d86ceee2971a84c2bce8d7a5c SHA512 e826883b50e04c6dc3340b51d7b3d3f3fc2bb91cf4e5c13367341449d5a57618d5918946416994f6acbf3e13ab38bafe435fb9ad4542d5e3bb1dfb08f202adf4
DIST libiscsi-1.19.0.tar.gz 284969 BLAKE2B 4e5dc37ba3393076dfc0ed8df0cf969771b16deeeffaf0b65741d1466103bf32b45c22566a6ccb43a5f8740a7681b78f8374ef041a96a59ac1b67ee7fc781cf3 SHA512 2c0e70b7ecf66204524e57edf557a014b5141a8819e5d663b6e50cb2e756fd634ae1db0b1ca6915444d80a9babd54a82619bdd98726d16d4eeaf7b3c89cf3d53
+DIST libiscsi-1.19.0_p20230208.tar.gz 293283 BLAKE2B 8dafcdd87d66c8addea8734af264b1ce70ec7cbb7925becf1946b616821a94a0d22ed9a903f5f24c03d9b647353fc76a708cafed0f6482199a45cb628c143fff SHA512 d6416833b4e1352e91d869ae753fdc01968e303d5ce7de52f27692ce7f8d7ca4f648931d54f0ebfa1323f8b43531bfc81771ea0468af4dc9ad53df02c8bad55f
diff --git a/net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch b/net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch
new file mode 100644
index 000000000000..89d91c5c5ebf
--- /dev/null
+++ b/net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch
@@ -0,0 +1,24 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -166,6 +166,8 @@ if test x"$libiscsi_cv_HAVE_SG_IO" = x"yes"; then
+ AC_DEFINE(HAVE_SG_IO,1,[Whether we have SG_IO support])
+ fi
+
++AC_ARG_WITH([rdma], AS_HELP_STRING([--with-rdma], [Build with rdma support]))
++
+ AC_CACHE_CHECK([for iSER support],libiscsi_cv_HAVE_LINUX_ISER,[
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <infiniband/verbs.h>
+@@ -173,10 +175,10 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <rdma/rdma_verbs.h>]],
+ [[int ibv = IBV_WC_SEND;]])],
+ [libiscsi_cv_HAVE_LINUX_ISER=yes],[libiscsi_cv_HAVE_LINUX_ISER=no])])
+-if test x"$libiscsi_cv_HAVE_LINUX_ISER" = x"yes"; then
++if test x"$libiscsi_cv_HAVE_LINUX_ISER" = x"yes" && test "x$with_rdma" = "xyes"; then
+ AC_DEFINE(HAVE_LINUX_ISER,1,[Whether we have iSER support])
+ fi
+-AM_CONDITIONAL([HAVE_LINUX_ISER], [test $libiscsi_cv_HAVE_LINUX_ISER = yes])
++AM_CONDITIONAL([HAVE_LINUX_ISER], [test "x$with_rdma" = "xyes"])
+
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <rdma/rdma_cma.h>]], [[return RDMA_OPTION_ID_ACK_TIMEOUT;]])],[AC_DEFINE([HAVE_RDMA_ACK_TIMEOUT],[1],[Define to 1 if you have RDMA ack timeout support])],[])
diff --git a/net-libs/libiscsi/libiscsi-1.19.0_p20230208.ebuild b/net-libs/libiscsi/libiscsi-1.19.0_p20230208.ebuild
new file mode 100644
index 000000000000..bc9b407ec658
--- /dev/null
+++ b/net-libs/libiscsi/libiscsi-1.19.0_p20230208.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
+ inherit git-r3
+else
+ if [[ ${PV} == *_p* ]] ; then
+ # The S path is too long for the test suite otherwise.
+ inherit vcs-snapshot
+
+ MY_COMMIT="22f7b26567760921fa1aad77cca642153123ea8c"
+ SRC_URI="https://github.com/sahlberg/libiscsi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="iscsi client library and utilities"
+HOMEPAGE="https://github.com/sahlberg/libiscsi"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE="rdma test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libgcrypt:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cunit )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19.0_p20230208-fix-rdma-automagic.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-manpages \
+ $(use_with rdma) \
+ --disable-werror \
+ $(use_enable test tests)
+}
+
+src_test() {
+ emake -C tests test
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/net-libs/libiscsi/libiscsi-9999.ebuild b/net-libs/libiscsi/libiscsi-9999.ebuild
index 6d289d4b8eb3..bc9b407ec658 100644
--- a/net-libs/libiscsi/libiscsi-9999.ebuild
+++ b/net-libs/libiscsi/libiscsi-9999.ebuild
@@ -9,7 +9,16 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/sahlberg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ if [[ ${PV} == *_p* ]] ; then
+ # The S path is too long for the test suite otherwise.
+ inherit vcs-snapshot
+
+ MY_COMMIT="22f7b26567760921fa1aad77cca642153123ea8c"
+ SRC_URI="https://github.com/sahlberg/libiscsi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
@@ -19,8 +28,7 @@ HOMEPAGE="https://github.com/sahlberg/libiscsi"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
IUSE="rdma test"
-# test_9000_compareandwrite.sh failure needs investigation
-RESTRICT="!test? ( test ) test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/libgcrypt:=
@@ -31,6 +39,10 @@ DEPEND="
test? ( dev-util/cunit )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19.0_p20230208-fix-rdma-automagic.patch
+)
+
src_prepare() {
default
eautoreconf