summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-26 10:40:43 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-26 11:04:03 +0200
commit1a038df6df11743fe6ff4eaad6c029c974949ea2 (patch)
tree63020c4b4f0d916fa313fc11814a43947cf8837b /net-libs/libpcap/libpcap-1.8.1.ebuild
parentkde-misc/colord-kde: version bump (diff)
downloadgentoo-1a038df6df11743fe6ff4eaad6c029c974949ea2.tar.gz
gentoo-1a038df6df11743fe6ff4eaad6c029c974949ea2.tar.bz2
gentoo-1a038df6df11743fe6ff4eaad6c029c974949ea2.zip
net-libs/libpcap: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs/libpcap/libpcap-1.8.1.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-1.8.1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/net-libs/libpcap/libpcap-1.8.1.ebuild b/net-libs/libpcap/libpcap-1.8.1.ebuild
new file mode 100644
index 000000000000..96ea6bcb2011
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.8.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="
+ http://www.tcpdump.org/
+ https://github.com/the-tcpdump-group/libpcap
+"
+SRC_URI="
+ https://github.com/the-tcpdump-group/${PN}/archive/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth dbus netlink static-libs usb"
+
+RDEPEND="
+ bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
+ usb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ dbus? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ "${FILESDIR}"/${PN}-1.8.1-cross-compile.patch
+ "${FILESDIR}"/${PN}-1.8.1-darwin.patch
+ "${FILESDIR}"/${PN}-1.8.1-libnl.patch
+)
+
+src_prepare() {
+ default
+
+ mkdir bluetooth || die
+ cp "${FILESDIR}"/mgmt.h bluetooth/ || die
+
+ eapply_user
+
+ echo ${PV} > VERSION || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable usb) \
+ $(use_enable dbus) \
+ $(use_with netlink libnl) \
+ --enable-ipv6
+}
+
+multilib_src_compile() {
+ emake all shared
+}
+
+multilib_src_install_all() {
+ dodoc CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel}
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+ prune_libtool_files
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h
+ fi
+}