summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-11-26 10:34:03 -0500
committerCraig Andrews <candrews@gentoo.org>2023-11-26 10:35:14 -0500
commit2472eb44c7a45ad2fe842673a796ce7b219773d3 (patch)
treec09b410ff3108166f9047bafbcebe1b58e84900a /net-libs/nghttp3
parentwww-apps/radarr: drop 5.2.2.8288 (diff)
downloadgentoo-2472eb44c7a45ad2fe842673a796ce7b219773d3.tar.gz
gentoo-2472eb44c7a45ad2fe842673a796ce7b219773d3.tar.bz2
gentoo-2472eb44c7a45ad2fe842673a796ce7b219773d3.zip
net-libs/nghttp3: add 1.1.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-1.1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 972d55ba9cc5..9ebf023d8ba5 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1 +1,2 @@
DIST nghttp3-1.0.0.tar.xz 369384 BLAKE2B a36b0c75e3c3c44b76652ef7c344831abe6cc160724203b9cb0951416d19df5630ac09c4a5eaf60203a6afcb5eab452d53546d97082f06e4761533b5f7518556 SHA512 84d3207346da3807e56a6f9d7f826ae4174d5a0ba6c4bf1e71dd3f6a7e694eb8f2b9607ed862ffac7b29509521f8216aef3e0910425a65bc4e94ffa879f4d3d8
+DIST nghttp3-1.1.0.tar.xz 369832 BLAKE2B d6b5ddf7d5809159f4f4d4f8b1750009d05d686bdfdaa882d242cf729f6cc7a950d6095aa0ab22b18d2d9dd7132d0f493bacc635617b5c74f993052bcbb964ce SHA512 30330a8002a296be4441f88f444436baba5e989b8c07dc95c55b43c85de8c2f995b000e88c6d44dc98449c10d9648dd45f641b8b24c0577c3b93e90faeba78b4
diff --git a/net-libs/nghttp3/nghttp3-1.1.0.ebuild b/net-libs/nghttp3/nghttp3-1.1.0.ebuild
new file mode 100644
index 000000000000..7f4078fba594
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}