summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Quinn <code@danielquinn.org>2015-12-16 15:36:17 +0000
committerDaniel Quinn <code@danielquinn.org>2015-12-17 01:08:17 +0000
commit0b989c5d6de5322d071a81b2869db047ecae0d3e (patch)
tree095cc6f2eff89b365a4364e8fe34993a3a55b871 /net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
parentsys-kernel/hardened-sources: version bump to 4.3.3 (diff)
downloadgentoo-0b989c5d6de5322d071a81b2869db047ecae0d3e.tar.gz
gentoo-0b989c5d6de5322d071a81b2869db047ecae0d3e.tar.bz2
gentoo-0b989c5d6de5322d071a81b2869db047ecae0d3e.zip
net-libs/ripe-atlas-sagan: Initial commit
Diffstat (limited to 'net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild')
-rw-r--r--net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild b/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
new file mode 100644
index 000000000000..8a26303832bf
--- /dev/null
+++ b/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="A parsing library for RIPE Atlas result strings"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.sagan/ripe.atlas.sagan-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ dev-python/ipy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}