summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-12 08:47:43 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-12 08:50:39 +0200
commit0834406e46a929e17d5bb42f725a3f1e30bca6cf (patch)
treec40d11131ba98bafcc92d9c5a3ad432671195a94 /net-libs
parentprofiles/package.mask: remove Gnome 3.24 mask leftover (diff)
downloadgentoo-0834406e46a929e17d5bb42f725a3f1e30bca6cf.tar.gz
gentoo-0834406e46a929e17d5bb42f725a3f1e30bca6cf.tar.bz2
gentoo-0834406e46a929e17d5bb42f725a3f1e30bca6cf.zip
net-libs/gtk-vnc: security version bump 0.6.0 → 0.7.1, bug #608700
Add missing USE dependency on gtk+:3, bug #608818 Refs: https://bugs.gentoo.org/show_bug.cgi?id=608700 Closes: https://bugs.gentoo.org/show_bug.cgi?id=608818 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/Manifest1
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild2
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.7.1.ebuild172
3 files changed, 174 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/Manifest b/net-libs/gtk-vnc/Manifest
index d5fa3c8e2aed..a274811086f7 100644
--- a/net-libs/gtk-vnc/Manifest
+++ b/net-libs/gtk-vnc/Manifest
@@ -1 +1,2 @@
DIST gtk-vnc-0.6.0.tar.xz 439104 SHA256 9559348805e64d130dae569fee466930175dbe150d2649bb868b5c095f130433 SHA512 38d37753bd8c88d112c046eb8430383b073b6516c72660b3e53612986a6772b72e3e6037f61e7a3700980ab1509c1f44fbfe0b80594c8a5e5520df166212f158 WHIRLPOOL e156f368a9d70e90077253b031db49f5f58e2f248b3e15bc11340f01f6bcbd342cf08dd9810c8ee447ab372159d09c3353aa5ce6195f67c677e7c43a563a75c0
+DIST gtk-vnc-0.7.1.tar.xz 444380 SHA256 f34baa696615ef67666e8465b4d0ac563355e999a77d2cc42ad4625a24f7aab1 SHA512 5d62f60e1c9fe70f93a9d21c529145459f0d59d588631597d533ecba94864271d1095599db9447ac4843814be61af7a7c947f69e5a9cd26db7e811f2c4e95f0c WHIRLPOOL b4736926bbd8ad49c6b2dd2a1b921a35a9ca5b8987c04b03ea588efe09b3db20eade41204d0a0542ee683efd6d2ec23636c13bc2e214ed452d885aef1302902a
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild
index 6cb12b57a438..e8d0f456c9b3 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild
@@ -31,7 +31,7 @@ COMMON_DEPEND="
>=x11-libs/cairo-1.2
>=x11-libs/gtk+-2.18:2
x11-libs/libX11
- gtk3? ( >=x11-libs/gtk+-2.91.3:3 )
+ gtk3? ( >=x11-libs/gtk+-2.91.3:3[introspection?] )
introspection? ( >=dev-libs/gobject-introspection-0.9.4:= )
pulseaudio? ( media-sound/pulseaudio )
python? (
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.7.1.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.7.1.ebuild
new file mode 100644
index 000000000000..ddb11d399fc8
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.7.1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multibuild python-r1 vala
+
+DESCRIPTION="VNC viewer widget for GTK"
+HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples +gtk3 +introspection pulseaudio python sasl vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( gtk3 introspection )
+"
+
+# libview is used in examples/gvncviewer -- no need
+# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129)
+COMMON_DEPEND="
+ >=dev-libs/glib-2.30.1:2
+ >=dev-libs/libgcrypt-1.4.2:0=
+ dev-libs/libgpg-error
+ >=net-libs/gnutls-3.0:0=
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ gtk3? ( >=x11-libs/gtk+-2.91.3:3[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.4:= )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2:2[${PYTHON_USEDEP}] )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.9.4 )
+"
+# eautoreconf requires gnome-common
+
+compute_variants() {
+ MULTIBUILD_VARIANTS=( 2.0 )
+ use gtk3 && MULTIBUILD_VARIANTS+=( 3.0 )
+}
+
+src_prepare() {
+ prepare() {
+ mkdir -p "${BUILD_DIR}" || die
+
+ if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then
+ python_foreach_impl prepare
+ fi
+ }
+
+ local MULTIBUILD_VARIANTS
+ compute_variants
+ multibuild_foreach_variant prepare
+
+ # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk, upstream bug#744393
+ sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
+ -i src/Makefile.* || die
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with examples)
+ $(use_enable introspection)
+ $(use_with pulseaudio)
+ $(use_with sasl)
+ --with-coroutine=gthread
+ --without-libview
+ --disable-static
+ --disable-vala
+ )
+
+ configure_python() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ ${myconf[@]} \
+ --with-gtk=2.0 \
+ --with-python
+ }
+
+ configure_normal() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ ${myconf[@]} \
+ --with-gtk=${MULTIBUILD_VARIANT} \
+ --without-python
+
+ # for gtk3, python support is via gobject-introspection
+ # Ex: from gi.repository import GtkVnc
+ if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then
+ python_foreach_impl run_in_build_dir configure_python
+ fi
+ }
+
+ local MULTIBUILD_VARIANTS
+ compute_variants
+ multibuild_foreach_variant run_in_build_dir configure_normal
+}
+
+src_compile() {
+ compile_python() {
+ cd "${BUILD_DIR}"/src || die
+ # CPPFLAGS set to help find includes for gvnc.override
+ emake gtkvnc.la \
+ VPATH="${S}/src:${GTK2_BUILDDIR}/src:${BUILD_DIR}/src" \
+ CPPFLAGS="${CPPFLAGS} -I${GTK2_BUILDDIR}/src" \
+ gtkvnc_la_LIBADD="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la" \
+ gtkvnc_la_DEPENDENCIES="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la"
+ }
+
+ compile_normal() {
+ gnome2_src_compile
+
+ if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then
+ local GTK2_BUILDDIR="${BUILD_DIR}"
+ python_foreach_impl run_in_build_dir compile_python
+ fi
+ }
+
+ local MULTIBUILD_VARIANTS
+ compute_variants
+ multibuild_foreach_variant run_in_build_dir compile_normal
+}
+
+src_test() {
+ local MULTIBUILD_VARIANTS
+ compute_variants
+
+ multibuild_foreach_variant run_in_build_dir default
+}
+
+src_install() {
+ install_python() {
+ cd "${BUILD_DIR}"/src || die
+ emake install-pyexecLTLIBRARIES DESTDIR="${D}" \
+ VPATH="${S}/src:${GTK2_BUILDDIR}/src:${BUILD_DIR}/src" \
+ CPPFLAGS="${CPPFLAGS} -I${GTK2_BUILDDIR}/src" \
+ gtkvnc_la_LIBADD="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la" \
+ gtkvnc_la_DEPENDENCIES="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la"
+ }
+
+ install_normal() {
+ gnome2_src_install
+
+ if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then
+ local GTK2_BUILDDIR="${BUILD_DIR}"
+ python_foreach_impl run_in_build_dir install_python
+ fi
+ }
+
+ local MULTIBUILD_VARIANTS
+ compute_variants
+ multibuild_foreach_variant run_in_build_dir install_normal
+}