summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-10-09 10:48:33 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-10-09 11:07:08 -0400
commit244657656bcf861f0e87880fc099ba016e696f1f (patch)
tree550f78e8b28fa0e81fc518747ffa593e849a10c0 /net-libs
parentprofiles: mask net-libs/webkit-gtk-2.46.x while in development (diff)
downloadgentoo-244657656bcf861f0e87880fc099ba016e696f1f.tar.gz
gentoo-244657656bcf861f0e87880fc099ba016e696f1f.tar.bz2
gentoo-244657656bcf861f0e87880fc099ba016e696f1f.zip
net-libs/webkit-gtk: new 2.46.x development ebuilds
These are masked, but it's easier to work on them if they're in the tree. Especially as I am not the usual maintainer, I'd like to avoid a duplication of effort in case someone else is interested in these. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/Manifest1
-rw-r--r--net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch43
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.46.1-r410.ebuild255
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.46.1-r600.ebuild274
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.46.1.ebuild255
5 files changed, 828 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index eaa0b83fa672..4a0036f2d229 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -1,2 +1,3 @@
DIST webkitgtk-2.44.1.tar.xz 36280696 BLAKE2B a5fff4c4fe90bcd0ea098930e51a36ea60152da47fd06e78abbc10f146437838aa19fed15cf58732b538046e1f42d8461cd5c0e0859096506932c9fae150cc16 SHA512 b1752303f9ee38ef98c1e5c0cad001d389eaedbbf07d13fed8699104e6e311cb47a9bed7089868cb92c53d2777aaff441147353da13123d5c8eee4adf8709169
DIST webkitgtk-2.44.4.tar.xz 35858056 BLAKE2B 9e3d016bfb2b4e80d2ebeda95e75f8ec8b909b41b17a879d3e1119ed66e3bf4d590a22ed814bb1572dac8d8a8838bb37b5ab1372121b276e02ee8925f6c5b00c SHA512 037ef6a9faca68b68dc62927a475134450493129043ea6cc03595cd4a684d590f80a1e9c3ed40a9176874ba43fc9efbc5065a264dfe131ebd72e272756612db9
+DIST webkitgtk-2.46.1.tar.xz 42776840 BLAKE2B 784b4cc4d59da31000612955413608f7a39481c66711139a7c8bc4cf854a62801865a6b3455d6a05918297b2ff3c9ba38ea9046f338ea6060768192af6d67bcd SHA512 e1ac92305b1d1b034eea9be6aa22cfa260249562fa0af41f0ed5c76a36916bba432073e033f228978d84d0377f245642ff31cdec324565e83aa8c82d8ea0c1f5
diff --git a/net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch b/net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch
new file mode 100644
index 000000000000..7c9110280020
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.46.1-riscv-buildfix.patch
@@ -0,0 +1,43 @@
+From 2f69282c9271c76e8783412766a50477288e5888 Mon Sep 17 00:00:00 2001
+From: Markus Volk <f_l_k@t-online.de>
+Date: Thu, 3 Oct 2024 12:34:03 +0200
+Subject: [PATCH] JavaScriptCore/jit/GPRInfo.h: fix typo in RISCV64Registers
+
+RICSV64Registers -> RISCV64Registers
+
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+---
+ Source/JavaScriptCore/jit/GPRInfo.h | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Source/JavaScriptCore/jit/GPRInfo.h b/Source/JavaScriptCore/jit/GPRInfo.h
+index fa7bf0aac48de..df5871957b3f5 100644
+--- a/Source/JavaScriptCore/jit/GPRInfo.h
++++ b/Source/JavaScriptCore/jit/GPRInfo.h
+@@ -779,16 +779,16 @@ class GPRInfo {
+ static constexpr GPRReg wasmBaseMemoryPointer = regCS3;
+ static constexpr GPRReg wasmBoundsCheckingSizeRegister = regCS4;
+
+- static constexpr GPRReg regWS0 = RICSV64Registers::x6;
+- static constexpr GPRReg regWS1 = RICSV64Registers::x7;
+- static constexpr GPRReg regWA0 = RICSV64Registers::x10;
+- static constexpr GPRReg regWA1 = RICSV64Registers::x11;
+- static constexpr GPRReg regWA2 = RICSV64Registers::x12;
+- static constexpr GPRReg regWA3 = RICSV64Registers::x13;
+- static constexpr GPRReg regWA4 = RICSV64Registers::x14;
+- static constexpr GPRReg regWA5 = RICSV64Registers::x15;
+- static constexpr GPRReg regWA6 = RICSV64Registers::x16;
+- static constexpr GPRReg regWA7 = RICSV64Registers::x17;
++ static constexpr GPRReg regWS0 = RISCV64Registers::x6;
++ static constexpr GPRReg regWS1 = RISCV64Registers::x7;
++ static constexpr GPRReg regWA0 = RISCV64Registers::x10;
++ static constexpr GPRReg regWA1 = RISCV64Registers::x11;
++ static constexpr GPRReg regWA2 = RISCV64Registers::x12;
++ static constexpr GPRReg regWA3 = RISCV64Registers::x13;
++ static constexpr GPRReg regWA4 = RISCV64Registers::x14;
++ static constexpr GPRReg regWA5 = RISCV64Registers::x15;
++ static constexpr GPRReg regWA6 = RISCV64Registers::x16;
++ static constexpr GPRReg regWA7 = RISCV64Registers::x17;
+
+ static constexpr GPRReg patchpointScratchRegister = RISCV64Registers::x30; // Should match dataTempRegister
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.46.1-r410.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.46.1-r410.ebuild
new file mode 100644
index 000000000000..d7ad93f005eb
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-2.46.1-r410.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{10..13} )
+USE_RUBY="ruby31 ruby32 ruby33"
+
+inherit check-reqs flag-o-matic gnome2 optfeature python-any-r1 ruby-single toolchain-funcs cmake
+
+MY_P="webkitgtk-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="https://www.webkitgtk.org"
+SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="4.1/0" # soname version of libwebkit2gtk-4.1
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="aqua avif examples gamepad keyring +gstreamer +introspection pdf jpegxl +jumbo-build lcms seccomp spell systemd wayland X"
+REQUIRED_USE="|| ( aqua wayland X )"
+
+# Tests do not run when built from tarballs
+# https://bugs.webkit.org/show_bug.cgi?id=215986
+RESTRICT="test"
+
+# Dependencies can be found in Source/cmake/OptionsGTK.cmake.
+#
+# * Missing WebRTC support, but ENABLE_WEB_RTC is experimental upstream.
+#
+# * media-libs/mesa dep is for libgbm
+#
+# * >=gst-plugins-opus-1.14.4-r1 for opusparse (required by MSE)
+#
+# * TODO: gst-plugins-base[X] is only needed when build configuration ends up
+# with GLX set, but that's a bit automagic too to fix
+#
+# * Cairo is only needed on big-endian systems, where Skia is not officially
+# supported (the build system will choose a backend for you). We could probably
+# hard-code a list of BE arches here, to avoid the extra dependency? But I am
+# holding out hope that this might actually get fixed before we need to do that.
+#
+# * dev-util/sysprof-capture is disabled because it was a new dependency in 2.46
+# and we don't need any more new problems.
+#
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/hyphen
+ dev-libs/icu:=
+ dev-libs/libgcrypt:0=
+ dev-libs/libtasn1:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/harfbuzz:=[icu(+)]
+ media-libs/libjpeg-turbo:0=
+ media-libs/libepoxy[egl(+)]
+ media-libs/libglvnd
+ media-libs/libpng:0=
+ media-libs/libwebp:=
+ media-libs/mesa
+ media-libs/woff2
+ net-libs/libsoup:3.0[introspection?]
+ sys-libs/zlib:0
+ x11-libs/cairo[X?]
+ x11-libs/gtk+:3[aqua?,introspection?,wayland?,X?]
+ x11-libs/libdrm
+ avif? ( media-libs/libavif:= )
+ gamepad? ( dev-libs/libmanette )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0[egl,opengl,X?]
+ media-plugins/gst-plugins-opus:1.0
+ media-libs/gst-plugins-bad:1.0
+ )
+ introspection? ( dev-libs/gobject-introspection:= )
+ jpegxl? ( media-libs/libjxl:= )
+ keyring? ( app-crypt/libsecret )
+ lcms? ( media-libs/lcms:2 )
+ seccomp? (
+ sys-apps/bubblewrap
+ sys-libs/libseccomp
+ sys-apps/xdg-dbus-proxy
+ )
+ spell? ( app-text/enchant:2 )
+ systemd? ( sys-apps/systemd:= )
+ X? ( x11-libs/libX11 )
+ wayland? (
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ )
+"
+DEPEND="${RDEPEND}"
+# Need real bison, not yacc
+BDEPEND="
+ ${PYTHON_DEPS}
+ ${RUBY_DEPS}
+ app-accessibility/at-spi2-core
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gperf
+ dev-util/unifdef
+ sys-devel/bison
+ sys-devel/gettext
+ virtual/perl-Data-Dumper
+ virtual/perl-Carp
+ virtual/perl-JSON-PP
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
+
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+# We cannot use PATCHES because src_prepare() calls cmake_src_prepare and
+# gnome2_src_prepare, and both apply ${PATCHES[@]}
+PATCHES=()
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+
+ if ! test-flag-CXX -std=c++17 ; then
+ die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
+ fi
+
+ if ! tc-is-clang ; then
+ ewarn "Upstream recommends that Clang be used to compile WebkitGTK:"
+ ewarn " https://webkitgtk.org/2024/10/04/webkitgtk-2.46.html"
+ fi
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ check-reqs_pkg_setup
+ fi
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+
+ eapply "${FILESDIR}/2.46.1-riscv-buildfix.patch"
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
+ # It does not compile on alpha without this in LDFLAGS
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co., bug #???
+ use sparc && filter-flags "-mvis"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # Try to use less memory, bug #469942 (see Fedora .spec for reference)
+ append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
+
+ # Ruby situation is a bit complicated. See bug 513888
+ local rubyimpl
+ local ruby_interpreter=""
+ local RUBY
+ for rubyimpl in ${USE_RUBY}; do
+ if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}(-)]"; then
+ RUBY="$(type -P ${rubyimpl})"
+ ruby_interpreter="-DRUBY_EXECUTABLE=${RUBY}"
+ fi
+ done
+ # This will rarely occur. Only a couple of corner cases could lead us to
+ # that failure. See bug 513888
+ [[ -z ${ruby_interpreter} ]] && die "No suitable ruby interpreter found"
+ # JavaScriptCore/Scripts/postprocess-asm invokes another Ruby script directly
+ # so it doesn't respect RUBY_EXECUTABLE, bug #771744.
+ sed -i -e "s:#!/usr/bin/env ruby:#!${RUBY}:" $(grep -rl "/usr/bin/env ruby" Source/JavaScriptCore || die) || die
+
+ # TODO: Check Web Audio support
+ # should somehow let user select between them?
+ local mycmakeargs=(
+ -DPython_EXECUTABLE="${PYTHON}"
+ ${ruby_interpreter}
+ # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
+ -DBWRAP_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/bwrap
+ -DDBUS_PROXY_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/xdg-dbus-proxy
+ -DPORT=GTK
+ # Source/cmake/WebKitFeatures.cmake
+ -DENABLE_API_TESTS=OFF
+ -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
+ -DENABLE_GAMEPAD=$(usex gamepad)
+ -DENABLE_GEOLOCATION=ON # Runtime optional (talks over dbus service)
+ -DENABLE_MINIBROWSER=$(usex examples)
+ -DENABLE_PDFJS=$(usex pdf)
+ -DENABLE_SPELLCHECK=$(usex spell)
+ -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
+ -DENABLE_VIDEO=$(usex gstreamer)
+ -DENABLE_WEB_AUDIO=$(usex gstreamer)
+ -DENABLE_WEB_CODECS=$(usex gstreamer) # https://bugs.webkit.org/show_bug.cgi?id=269147
+ -DENABLE_WEBDRIVER=OFF
+ -DENABLE_WEBGL=ON
+ -DUSE_AVIF=$(usex avif)
+ -DUSE_GSTREAMER_WEBRTC=$(usex gstreamer)
+ -DUSE_GSTREAMER_TRANSCODER=$(usex gstreamer)
+ # Source/cmake/OptionsGTK.cmake
+ -DENABLE_DOCUMENTATION=OFF
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DENABLE_JOURNALD_LOG=$(usex systemd)
+ -DENABLE_QUARTZ_TARGET=$(usex aqua)
+ -DENABLE_WAYLAND_TARGET=$(usex wayland)
+ -DENABLE_X11_TARGET=$(usex X)
+ -DUSE_GBM=ON
+ -DUSE_GTK4=OFF
+ -DUSE_JPEGXL=$(usex jpegxl)
+ -DUSE_LCMS=$(usex lcms)
+ -DUSE_LIBBACKTRACE=OFF
+ -DUSE_LIBDRM=ON
+ -DUSE_LIBHYPHEN=ON
+ -DUSE_LIBSECRET=$(usex keyring)
+ -DUSE_SOUP2=OFF
+ -DUSE_SYSPROF_CAPTURE=OFF
+ -DUSE_WOFF2=ON
+ )
+
+ # Temporary workaround for bug 938162 (upstream bug 271371).
+ use riscv && mycmakeargs+=( -DENABLE_JIT=OFF )
+
+ # https://bugs.gentoo.org/761238
+ append-cppflags -DNDEBUG
+
+ WK_USE_CCACHE=NO cmake_src_configure
+}
+
+pkg_postinst() {
+ optfeature "geolocation service (used at runtime if available)" "app-misc/geoclue"
+ optfeature "Common Multimedia codecs" "media-plugins/gst-plugins-meta"
+ optfeature "VAAPI encoding support" "media-libs/gst-plugins-bad[vaapi]"
+ optfeature "MPEG-DASH support" "media-plugins/gst-plugins-dash"
+ optfeature "HTTP live streaming (HLS) support" "media-plugins/gst-plugins-hls"
+}
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.46.1-r600.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.46.1-r600.ebuild
new file mode 100644
index 000000000000..8c4f3556c6b3
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-2.46.1-r600.ebuild
@@ -0,0 +1,274 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{10..13} )
+USE_RUBY="ruby31 ruby32 ruby33"
+
+inherit check-reqs flag-o-matic gnome2 optfeature python-any-r1 ruby-single toolchain-funcs cmake
+
+MY_P="webkitgtk-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="https://www.webkitgtk.org"
+SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="6/0" # soname version of libwebkit2gtk-6.0
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="aqua avif examples gamepad keyring +gstreamer +introspection pdf jpegxl +jumbo-build lcms seccomp spell systemd wayland X"
+REQUIRED_USE="|| ( aqua wayland X )"
+
+# Tests do not run when built from tarballs
+# https://bugs.webkit.org/show_bug.cgi?id=215986
+RESTRICT="test"
+
+# Dependencies can be found in Source/cmake/OptionsGTK.cmake.
+#
+# * Missing WebRTC support, but ENABLE_WEB_RTC is experimental upstream.
+#
+# * media-libs/mesa dep is for libgbm
+#
+# * >=gst-plugins-opus-1.14.4-r1 for opusparse (required by MSE)
+#
+# * TODO: gst-plugins-base[X] is only needed when build configuration ends up
+# with GLX set, but that's a bit automagic too to fix
+#
+# * Softblocking <webkit-gtk-2.38:4 and <webkit-gtk-2.44:4.1 as since
+# 2.44 this SLOT ships the WebKitWebDriver binary; WebKitWebDriver is
+# an automation tool for web developers, which lets one control the
+# browser via WebDriver API - only one SLOT can ship it.
+#
+# * at-spi2-core (atspi-2.pc) is checked at build time, but not linked
+# to in the gtk4 SLOT - is it an upstream check bug and only gtk-4.14
+# a11y support is used?
+#
+# * Cairo is only needed on big-endian systems, where Skia is not officially
+# supported (the build system will choose a backend for you). We could probably
+# hard-code a list of BE arches here, to avoid the extra dependency? But I am
+# holding out hope that this might actually get fixed before we need to do that.
+#
+# * dev-util/sysprof-capture is disabled because it was a new dependency in 2.46
+# and we don't need any more new problems.
+#
+RDEPEND="
+ !<net-libs/webkit-gtk-2.38:4
+ !<net-libs/webkit-gtk-2.44:4.1
+ app-accessibility/at-spi2-core:2
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/hyphen
+ dev-libs/icu:=
+ dev-libs/libgcrypt:0=
+ dev-libs/libtasn1:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=gui-libs/gtk-4.14.0:4[aqua?,introspection?,wayland?,X?]
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/harfbuzz:=[icu(+)]
+ media-libs/libjpeg-turbo:0=
+ media-libs/libepoxy[egl(+)]
+ media-libs/libglvnd
+ media-libs/libpng:0=
+ media-libs/libwebp:=
+ media-libs/mesa
+ media-libs/woff2
+ net-libs/libsoup:3.0[introspection?]
+ sys-libs/zlib:0
+ x11-libs/cairo[X?]
+ x11-libs/libdrm
+ avif? ( media-libs/libavif:= )
+ gamepad? ( dev-libs/libmanette )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0[egl,opengl,X?]
+ media-plugins/gst-plugins-opus:1.0
+ media-libs/gst-plugins-bad:1.0
+ )
+ introspection? ( dev-libs/gobject-introspection:= )
+ jpegxl? ( media-libs/libjxl:= )
+ keyring? ( app-crypt/libsecret )
+ lcms? ( media-libs/lcms:2 )
+ seccomp? (
+ sys-apps/bubblewrap
+ sys-libs/libseccomp
+ sys-apps/xdg-dbus-proxy
+ )
+ spell? ( app-text/enchant:2 )
+ systemd? ( sys-apps/systemd:= )
+ X? ( x11-libs/libX11 )
+ wayland? (
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ )
+"
+DEPEND="${RDEPEND}"
+# Need real bison, not yacc
+BDEPEND="
+ ${PYTHON_DEPS}
+ ${RUBY_DEPS}
+ app-accessibility/at-spi2-core
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gperf
+ dev-util/unifdef
+ sys-devel/bison
+ sys-devel/gettext
+ virtual/perl-Data-Dumper
+ virtual/perl-Carp
+ virtual/perl-JSON-PP
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
+
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+# We cannot use PATCHES because src_prepare() calls cmake_src_prepare and
+# gnome2_src_prepare, and both apply ${PATCHES[@]}
+PATCHES=()
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+
+ if ! test-flag-CXX -std=c++17 ; then
+ die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
+ fi
+
+ if ! tc-is-clang ; then
+ ewarn "Upstream recommends that Clang be used to compile WebkitGTK:"
+ ewarn " https://webkitgtk.org/2024/10/04/webkitgtk-2.46.html"
+ fi
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ check-reqs_pkg_setup
+ fi
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+
+ eapply "${FILESDIR}/2.46.1-riscv-buildfix.patch"
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
+ # It does not compile on alpha without this in LDFLAGS
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co., bug #???
+ use sparc && filter-flags "-mvis"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # Try to use less memory, bug #469942 (see Fedora .spec for reference)
+ append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
+
+ # Ruby situation is a bit complicated. See bug 513888
+ local rubyimpl
+ local ruby_interpreter=""
+ local RUBY
+ for rubyimpl in ${USE_RUBY}; do
+ if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}(-)]"; then
+ RUBY="$(type -P ${rubyimpl})"
+ ruby_interpreter="-DRUBY_EXECUTABLE=${RUBY}"
+ fi
+ done
+ # This will rarely occur. Only a couple of corner cases could lead us to
+ # that failure. See bug 513888
+ [[ -z ${ruby_interpreter} ]] && die "No suitable ruby interpreter found"
+ # JavaScriptCore/Scripts/postprocess-asm invokes another Ruby script directly
+ # so it doesn't respect RUBY_EXECUTABLE, bug #771744.
+ sed -i -e "s:#!/usr/bin/env ruby:#!${RUBY}:" $(grep -rl "/usr/bin/env ruby" Source/JavaScriptCore || die) || die
+
+ # TODO: Check Web Audio support
+ # should somehow let user select between them?
+ local mycmakeargs=(
+ -DPython_EXECUTABLE="${PYTHON}"
+ ${ruby_interpreter}
+ # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
+ -DBWRAP_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/bwrap
+ -DDBUS_PROXY_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/xdg-dbus-proxy
+ -DPORT=GTK
+ # Source/cmake/WebKitFeatures.cmake
+ -DENABLE_API_TESTS=OFF
+ -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
+ -DENABLE_GAMEPAD=$(usex gamepad)
+ -DENABLE_GEOLOCATION=ON # Runtime optional (talks over dbus service)
+ -DENABLE_MINIBROWSER=$(usex examples)
+ -DENABLE_PDFJS=$(usex pdf)
+ -DENABLE_SPELLCHECK=$(usex spell)
+ -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
+ -DENABLE_VIDEO=$(usex gstreamer)
+ -DENABLE_WEB_AUDIO=$(usex gstreamer)
+ -DENABLE_WEB_CODECS=$(usex gstreamer) # https://bugs.webkit.org/show_bug.cgi?id=269147
+ -DENABLE_WEBDRIVER=ON
+ -DENABLE_WEBGL=ON
+ -DUSE_AVIF=$(usex avif)
+ -DUSE_GSTREAMER_WEBRTC=$(usex gstreamer)
+ -DUSE_GSTREAMER_TRANSCODER=$(usex gstreamer)
+ # Source/cmake/OptionsGTK.cmake
+ -DENABLE_DOCUMENTATION=OFF
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DENABLE_JOURNALD_LOG=$(usex systemd)
+ -DENABLE_QUARTZ_TARGET=$(usex aqua)
+ -DENABLE_WAYLAND_TARGET=$(usex wayland)
+ -DENABLE_X11_TARGET=$(usex X)
+ -DUSE_GBM=ON
+ -DUSE_GTK4=ON # webkit2gtk-6.0
+ -DUSE_JPEGXL=$(usex jpegxl)
+ -DUSE_LCMS=$(usex lcms)
+ -DUSE_LIBBACKTRACE=OFF
+ -DUSE_LIBDRM=ON
+ -DUSE_LIBHYPHEN=ON
+ -DUSE_LIBSECRET=$(usex keyring)
+ -DUSE_SOUP2=OFF
+ -DUSE_SYSPROF_CAPTURE=OFF
+ -DUSE_WOFF2=ON
+ )
+
+ # Temporary workaround for bug 938162 (upstream bug 271371).
+ use riscv && mycmakeargs+=( -DENABLE_JIT=OFF )
+
+ # https://bugs.gentoo.org/761238
+ append-cppflags -DNDEBUG
+
+ WK_USE_CCACHE=NO cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /usr/share/gtk-doc/html
+ # This will install API docs specific to webkit2gtk-6.0
+ doins -r "${S}"/Documentation/{jsc-glib,webkitgtk,webkitgtk-web-process-extension}-6.0
+}
+
+pkg_postinst() {
+ optfeature "geolocation service (used at runtime if available)" "app-misc/geoclue"
+ optfeature "Common Multimedia codecs" "media-plugins/gst-plugins-meta"
+ optfeature "VAAPI encoding support" "media-libs/gst-plugins-bad[vaapi]"
+ optfeature "MPEG-DASH support" "media-plugins/gst-plugins-dash"
+ optfeature "HTTP live streaming (HLS) support" "media-plugins/gst-plugins-hls"
+}
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.46.1.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.46.1.ebuild
new file mode 100644
index 000000000000..ae809ea078f4
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-2.46.1.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{10..13} )
+USE_RUBY="ruby31 ruby32 ruby33"
+
+inherit check-reqs flag-o-matic gnome2 optfeature python-any-r1 ruby-single toolchain-funcs cmake
+
+MY_P="webkitgtk-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="https://www.webkitgtk.org"
+SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="4/37" # soname version of libwebkit2gtk-4.0
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="aqua avif examples gamepad keyring +gstreamer +introspection pdf jpegxl +jumbo-build lcms seccomp spell systemd wayland X"
+REQUIRED_USE="|| ( aqua wayland X )"
+
+# Tests do not run when built from tarballs
+# https://bugs.webkit.org/show_bug.cgi?id=215986
+RESTRICT="test"
+
+# Dependencies can be found in Source/cmake/OptionsGTK.cmake.
+#
+# * Missing WebRTC support, but ENABLE_WEB_RTC is experimental upstream.
+#
+# * media-libs/mesa dep is for libgbm
+#
+# * >=gst-plugins-opus-1.14.4-r1 for opusparse (required by MSE)
+#
+# * TODO: gst-plugins-base[X] is only needed when build configuration ends up
+# with GLX set, but that's a bit automagic too to fix
+#
+# * Cairo is only needed on big-endian systems, where Skia is not officially
+# supported (the build system will choose a backend for you). We could probably
+# hard-code a list of BE arches here, to avoid the extra dependency? But I am
+# holding out hope that this might actually get fixed before we need to do that.
+#
+# * dev-util/sysprof-capture is disabled because it was a new dependency in 2.46
+# and we don't need any more new problems.
+#
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/hyphen
+ dev-libs/icu:=
+ dev-libs/libgcrypt:0=
+ dev-libs/libtasn1:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/harfbuzz:=[icu(+)]
+ media-libs/libjpeg-turbo:0=
+ media-libs/libepoxy[egl(+)]
+ media-libs/libglvnd
+ media-libs/libpng:0=
+ media-libs/libwebp:=
+ media-libs/mesa
+ media-libs/woff2
+ net-libs/libsoup:2.4[introspection?]
+ sys-libs/zlib:0
+ x11-libs/cairo[X?]
+ x11-libs/gtk+:3[aqua?,introspection?,wayland?,X?]
+ x11-libs/libdrm
+ avif? ( media-libs/libavif:= )
+ gamepad? ( dev-libs/libmanette )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0[egl,opengl,X?]
+ media-plugins/gst-plugins-opus:1.0
+ media-libs/gst-plugins-bad:1.0
+ )
+ introspection? ( dev-libs/gobject-introspection:= )
+ jpegxl? ( media-libs/libjxl:= )
+ keyring? ( app-crypt/libsecret )
+ lcms? ( media-libs/lcms:2 )
+ seccomp? (
+ sys-apps/bubblewrap
+ sys-libs/libseccomp
+ sys-apps/xdg-dbus-proxy
+ )
+ spell? ( app-text/enchant:2 )
+ systemd? ( sys-apps/systemd:= )
+ X? ( x11-libs/libX11 )
+ wayland? (
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ )
+"
+DEPEND="${RDEPEND}"
+# Need real bison, not yacc
+BDEPEND="
+ ${PYTHON_DEPS}
+ ${RUBY_DEPS}
+ app-accessibility/at-spi2-core
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gperf
+ dev-util/unifdef
+ sys-devel/bison
+ sys-devel/gettext
+ virtual/perl-Data-Dumper
+ virtual/perl-Carp
+ virtual/perl-JSON-PP
+ virtual/pkgconfig
+ wayland? ( dev-util/wayland-scanner )
+"
+
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+# We cannot use PATCHES because src_prepare() calls cmake_src_prepare and
+# gnome2_src_prepare, and both apply ${PATCHES[@]}
+PATCHES=()
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+
+ if ! test-flag-CXX -std=c++17 ; then
+ die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
+ fi
+
+ if ! tc-is-clang ; then
+ ewarn "Upstream recommends that Clang be used to compile WebkitGTK:"
+ ewarn " https://webkitgtk.org/2024/10/04/webkitgtk-2.46.html"
+ fi
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ check-reqs_pkg_setup
+ fi
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+
+ eapply "${FILESDIR}/2.46.1-riscv-buildfix.patch"
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # ODR violations (bug #915230, https://bugs.webkit.org/show_bug.cgi?id=233007)
+ filter-lto
+
+ # It does not compile on alpha without this in LDFLAGS
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co., bug #???
+ use sparc && filter-flags "-mvis"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # Try to use less memory, bug #469942 (see Fedora .spec for reference)
+ append-ldflags $(test-flags-CCLD "-Wl,--no-keep-memory")
+
+ # Ruby situation is a bit complicated. See bug 513888
+ local rubyimpl
+ local ruby_interpreter=""
+ local RUBY
+ for rubyimpl in ${USE_RUBY}; do
+ if has_version -b "virtual/rubygems[ruby_targets_${rubyimpl}(-)]"; then
+ RUBY="$(type -P ${rubyimpl})"
+ ruby_interpreter="-DRUBY_EXECUTABLE=${RUBY}"
+ fi
+ done
+ # This will rarely occur. Only a couple of corner cases could lead us to
+ # that failure. See bug 513888
+ [[ -z ${ruby_interpreter} ]] && die "No suitable ruby interpreter found"
+ # JavaScriptCore/Scripts/postprocess-asm invokes another Ruby script directly
+ # so it doesn't respect RUBY_EXECUTABLE, bug #771744.
+ sed -i -e "s:#!/usr/bin/env ruby:#!${RUBY}:" $(grep -rl "/usr/bin/env ruby" Source/JavaScriptCore || die) || die
+
+ # TODO: Check Web Audio support
+ # should somehow let user select between them?
+ local mycmakeargs=(
+ -DPython_EXECUTABLE="${PYTHON}"
+ ${ruby_interpreter}
+ # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
+ -DBWRAP_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/bwrap
+ -DDBUS_PROXY_EXECUTABLE:FILEPATH="${EPREFIX}"/usr/bin/xdg-dbus-proxy
+ -DPORT=GTK
+ # Source/cmake/WebKitFeatures.cmake
+ -DENABLE_API_TESTS=OFF
+ -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
+ -DENABLE_GAMEPAD=$(usex gamepad)
+ -DENABLE_GEOLOCATION=ON # Runtime optional (talks over dbus service)
+ -DENABLE_MINIBROWSER=$(usex examples)
+ -DENABLE_PDFJS=$(usex pdf)
+ -DENABLE_SPELLCHECK=$(usex spell)
+ -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
+ -DENABLE_VIDEO=$(usex gstreamer)
+ -DENABLE_WEB_AUDIO=$(usex gstreamer)
+ -DENABLE_WEB_CODECS=$(usex gstreamer) # https://bugs.webkit.org/show_bug.cgi?id=269147
+ -DENABLE_WEBDRIVER=OFF
+ -DENABLE_WEBGL=ON
+ -DUSE_AVIF=$(usex avif)
+ -DUSE_GSTREAMER_WEBRTC=$(usex gstreamer)
+ -DUSE_GSTREAMER_TRANSCODER=$(usex gstreamer)
+ # Source/cmake/OptionsGTK.cmake
+ -DENABLE_DOCUMENTATION=OFF
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DENABLE_JOURNALD_LOG=$(usex systemd)
+ -DENABLE_QUARTZ_TARGET=$(usex aqua)
+ -DENABLE_WAYLAND_TARGET=$(usex wayland)
+ -DENABLE_X11_TARGET=$(usex X)
+ -DUSE_GBM=ON
+ -DUSE_GTK4=OFF
+ -DUSE_JPEGXL=$(usex jpegxl)
+ -DUSE_LCMS=$(usex lcms)
+ -DUSE_LIBBACKTRACE=OFF
+ -DUSE_LIBDRM=ON
+ -DUSE_LIBHYPHEN=ON
+ -DUSE_LIBSECRET=$(usex keyring)
+ -DUSE_SOUP2=ON
+ -DUSE_SYSPROF_CAPTURE=OFF
+ -DUSE_WOFF2=ON
+ )
+
+ # Temporary workaround for bug 938162 (upstream bug 271371).
+ use riscv && mycmakeargs+=( -DENABLE_JIT=OFF )
+
+ # https://bugs.gentoo.org/761238
+ append-cppflags -DNDEBUG
+
+ WK_USE_CCACHE=NO cmake_src_configure
+}
+
+pkg_postinst() {
+ optfeature "geolocation service (used at runtime if available)" "app-misc/geoclue"
+ optfeature "Common Multimedia codecs" "media-plugins/gst-plugins-meta"
+ optfeature "VAAPI encoding support" "media-libs/gst-plugins-bad[vaapi]"
+ optfeature "MPEG-DASH support" "media-plugins/gst-plugins-dash"
+ optfeature "HTTP live streaming (HLS) support" "media-plugins/gst-plugins-hls"
+}