summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-23 00:53:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-23 01:05:05 +0200
commit2d89beb5bdad410cba3e18a92d4e9db38589cbc0 (patch)
treea665667a760517230209d648460bd360d41c27e8 /net-libs
parentmedia-sound/spotify: 1.1.67 removal (diff)
downloadgentoo-2d89beb5bdad410cba3e18a92d4e9db38589cbc0.tar.gz
gentoo-2d89beb5bdad410cba3e18a92d4e9db38589cbc0.tar.bz2
gentoo-2d89beb5bdad410cba3e18a92d4e9db38589cbc0.zip
net-libs/telepathy-qt: EAPI-8, Add PYTHON_REQ_USE="xml(+)", python3_10
Closes: https://bugs.gentoo.org/812917 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild78
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-9999.ebuild6
2 files changed, 82 insertions, 2 deletions
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..9f392ed86abb
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="xml(+)"
+inherit python-any-r1 cmake virtualx
+
+DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="https://telepathy.freedesktop.org/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+IUSE="debug farstream test"
+
+REQUIRED_USE="test? ( farstream )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ farstream? (
+ >=net-libs/telepathy-farstream-0.2.2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/dbus-glib
+ dev-qt/qttest:5
+ )
+"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ test? (
+ dev-libs/glib:2
+ $(python_gen_any_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ use test || return 0
+ has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DENABLE_DEBUG_OUTPUT=$(usex debug)
+ -DENABLE_FARSTREAM=$(usex farstream)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # some tests require D-Bus, bug #732110
+ local myctestargs=(
+ -E "(BaseConnectionManager|BaseProtocol|StreamTubeHandlers)"
+ )
+ pushd "${BUILD_DIR}" > /dev/null || die
+ virtx cmake_src_test
+ popd > /dev/null || die
+}
diff --git a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
index 6e73cf75caee..4ae1fc73d370 100644
--- a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
@@ -3,9 +3,10 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="xml(+)"
-if [[ ${PV} = *9999* ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI=( "https://gitlab.freedesktop.org/telepathy/${PN}" )
inherit git-r3
else
@@ -63,6 +64,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
+ -DPython3_EXECUTABLE="${PYTHON}"
-DENABLE_DEBUG_OUTPUT=$(usex debug)
-DENABLE_FARSTREAM=$(usex farstream)
-DENABLE_TESTS=$(usex test)