summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2023-05-09 17:06:11 +0300
committerSam James <sam@gentoo.org>2023-05-10 20:42:33 +0100
commita566d1a5c7f9d722369d0b511f8a881b7804e2ef (patch)
treec1a9398893c58eb0115ab1ce741dbab0deb42f41 /net-libs
parentdev-util/scap-driver: fix build on kernel 6.3 (diff)
downloadgentoo-a566d1a5c7f9d722369d0b511f8a881b7804e2ef.tar.gz
gentoo-a566d1a5c7f9d722369d0b511f8a881b7804e2ef.tar.bz2
gentoo-a566d1a5c7f9d722369d0b511f8a881b7804e2ef.zip
net-libs/libmicrohttpd: fixed false positive QA warnings
Closes: https://bugs.gentoo.org/898662 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/30954 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.75.ebuild38
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild38
2 files changed, 76 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.75.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.75.ebuild
index 91a33a5ffc66..1bb9ef7f324f 100644
--- a/net-libs/libmicrohttpd/libmicrohttpd-0.9.75.ebuild
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.75.ebuild
@@ -28,6 +28,44 @@ DOCS=( AUTHORS NEWS COPYING README ChangeLog )
PATCHES=( "${FILESDIR}"/${P}-fix-testsuite-with-lto.patch )
+# All checks in libmicrohttpd's configure are correct
+# Gentoo Bug #898662
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'pthread_sigmask'
+ 'CreateThread'
+ 'pthread_attr_init'
+ 'pthread_attr_setname_np'
+ 'pthread_setname_np'
+ '__builtin_bswap32'
+ '__builtin_bswap64'
+ 'WSAPoll'
+ 'epoll_create1'
+ 'eventfd'
+ 'pipe'
+ 'pipe2'
+ 'socketpair'
+ 'gmtime_s'
+ 'host_get_clock_service'
+ 'clock_get_time'
+ 'mach_port_deallocate'
+ 'gethrtime'
+ 'timespec_get'
+ 'gettimeofday'
+ 'sendfile'
+ 'gnutls_privkey_import_x509_raw'
+ 'calloc'
+ 'fork'
+ 'waitpid'
+ 'random'
+ 'rand'
+ 'getsockname'
+ 'sysconf'
+ 'sysctl'
+ 'sysctlbyname'
+ 'usleep'
+ 'nanosleep'
+)
+
multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild
index a6645d2c91de..bf4d507938ba 100644
--- a/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.76.ebuild
@@ -28,6 +28,44 @@ DOCS=( AUTHORS NEWS COPYING README ChangeLog )
PATCHES=( "${FILESDIR}"/${PN}-0.9.75-fix-testsuite-with-lto.patch )
+# All checks in libmicrohttpd's configure are correct
+# Gentoo Bug #898662
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'pthread_sigmask'
+ 'CreateThread'
+ 'pthread_attr_init'
+ 'pthread_attr_setname_np'
+ 'pthread_setname_np'
+ '__builtin_bswap32'
+ '__builtin_bswap64'
+ 'WSAPoll'
+ 'epoll_create1'
+ 'eventfd'
+ 'pipe'
+ 'pipe2'
+ 'socketpair'
+ 'gmtime_s'
+ 'host_get_clock_service'
+ 'clock_get_time'
+ 'mach_port_deallocate'
+ 'gethrtime'
+ 'timespec_get'
+ 'gettimeofday'
+ 'sendfile'
+ 'gnutls_privkey_import_x509_raw'
+ 'calloc'
+ 'fork'
+ 'waitpid'
+ 'random'
+ 'rand'
+ 'getsockname'
+ 'sysconf'
+ 'sysctl'
+ 'sysctlbyname'
+ 'usleep'
+ 'nanosleep'
+)
+
multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \