summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-07-29 20:16:02 +0200
committerFabian Groffen <grobian@gentoo.org>2024-07-29 20:17:45 +0200
commitd14233d72e7cdc4e93acb83100118500f8822203 (patch)
tree313a45aae72402b6af08c4149489ebeb3d461c5f /net-libs
parentapp-i18n/libime: Stabilize 1.1.8 x86, #936885 (diff)
downloadgentoo-d14233d72e7cdc4e93acb83100118500f8822203.tar.gz
gentoo-d14233d72e7cdc4e93acb83100118500f8822203.tar.bz2
gentoo-d14233d72e7cdc4e93acb83100118500f8822203.zip
net-libs/gnutls-3.8.6-r1: adapt Solaris fix, deal with alloca
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/gnutls-3.8.6-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-libs/gnutls/gnutls-3.8.6-r1.ebuild b/net-libs/gnutls/gnutls-3.8.6-r1.ebuild
index 939e7b193225..2eadf62b1861 100644
--- a/net-libs/gnutls/gnutls-3.8.6-r1.ebuild
+++ b/net-libs/gnutls/gnutls-3.8.6-r1.ebuild
@@ -81,6 +81,13 @@ src_prepare() {
# fails to compile in certain configurations
sed -i -e 's/__APPLE__/__NO_APPLE__/' lib/system/certs.c || die
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # should be gone on next release, for gnulib memset_s breakage
+ append-cppflags -D__STDC_WANT_LIB_EXT1__=1
+ # alloca usage, similar
+ sed -i -e '$a#include <alloca.h>' config.h.in || die
+ fi
+
# Use sane .so versioning on FreeBSD.
elibtoolize
}
@@ -101,8 +108,6 @@ multilib_src_configure() {
# GNU-stack (as doesn't support that) and when that's removed ld
# complains about duplicate symbols
[[ ${CHOST} == *-darwin* ]] && libconf+=( --disable-hardware-acceleration )
- # should be gone on next release, for gnulib memset_s breakage
- [[ ${CHOST} == *-solaris* ]] && append-cppflags -D__STDC_WANT_LIB_EXT1__=1
# -fanalyzer substantially slows down the build and isn't useful for
# us. It's useful for upstream as it's static analysis, but it's not