summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/autorespond
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/autorespond')
-rw-r--r--net-mail/autorespond/Manifest3
-rw-r--r--net-mail/autorespond/autorespond-2.0.4.ebuild37
-rw-r--r--net-mail/autorespond/autorespond-2.0.5.ebuild39
-rw-r--r--net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch23
-rw-r--r--net-mail/autorespond/metadata.xml8
5 files changed, 110 insertions, 0 deletions
diff --git a/net-mail/autorespond/Manifest b/net-mail/autorespond/Manifest
new file mode 100644
index 000000000000..52f55baac771
--- /dev/null
+++ b/net-mail/autorespond/Manifest
@@ -0,0 +1,3 @@
+DIST autorespond-2.0.4.tar.gz 7884 SHA256 3778ffaea785ee1c0d949badca666423324b82ea101bba398b11c403451869a9
+DIST autorespond-2.0.5.tar.gz 9707 SHA256 d678dbaaf059a146055ed0bf597b03d4bd2d0edb247bd066dfa488b6af8ef8b5
+DIST autorespond_2.0.4-1.diff.gz 2637 SHA256 1b7cdf34d295d041bf1d60b5078d3f0cb818ec75d5276746870ad4f28ef83608
diff --git a/net-mail/autorespond/autorespond-2.0.4.ebuild b/net-mail/autorespond/autorespond-2.0.4.ebuild
new file mode 100644
index 000000000000..b7402ef9a103
--- /dev/null
+++ b/net-mail/autorespond/autorespond-2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DEBIAN_PV="1"
+DEBIAN_P="${P/-/_}-${DEBIAN_PV}"
+DESCRIPTION="Autoresponder add on package for qmailadmin"
+HOMEPAGE="http://inter7.com/devel/"
+SRC_URI="mirror://sourceforge/qmailadmin/${P}.tar.gz
+ mirror://debian/pool/contrib/${PN:0:1}/${PN}/${DEBIAN_P}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="virtual/qmail"
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch "${DISTDIR}"/${DEBIAN_P}.diff.gz
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ into /var/qmail
+ dobin autorespond || die "dobin failed"
+ into /usr
+ dodoc README help_message qmail-auto ChangeLog
+ doman *.1
+}
diff --git a/net-mail/autorespond/autorespond-2.0.5.ebuild b/net-mail/autorespond/autorespond-2.0.5.ebuild
new file mode 100644
index 000000000000..cc61de80bea5
--- /dev/null
+++ b/net-mail/autorespond/autorespond-2.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Autoresponder add on package for qmailadmin"
+HOMEPAGE="http://inter7.com/devel/"
+SRC_URI="http://inter7.com/devel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/qmail"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-no-include-bounce.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ into /var/qmail
+ dobin autorespond || die "dobin failed"
+ into /usr
+ dodoc README help_message qmail-auto #ChangeLog
+ doman *.1
+}
+
+pkg_postinst() {
+ ewarn "Please note that original messages are now NOT included with bounces"
+ ewarn "by default. Use the flag per the help output if you want them."
+}
diff --git a/net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch b/net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch
new file mode 100644
index 000000000000..5131ad16bcfa
--- /dev/null
+++ b/net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch
@@ -0,0 +1,23 @@
+diff -Nuar autorespond-2.0.5.orig/autorespond.c autorespond-2.0.5/autorespond.c
+--- autorespond-2.0.5.orig/autorespond.c 2003-09-18 13:17:57.000000000 -0700
++++ autorespond-2.0.5/autorespond.c 2008-06-24 20:46:15.615642827 -0700
+@@ -80,7 +80,7 @@
+ #include <sys/wait.h>
+ #include <ctype.h>
+
+-#define DEFAULT_MH 1 /* default value for message_handling flag */
++#define DEFAULT_MH 0 /* default value for message_handling flag */
+ #define DEFAULT_FROM "$" /* default "from" for the autorespond */
+
+ #define WITH_OMESSAGE 1
+@@ -562,8 +562,8 @@
+ fprintf(stderr, "dir - the directory to hold the log of messages\n\n");
+ fprintf(stderr, "optional parameters:\n\n");
+ fprintf(stderr, "flag - handling of original message:\n\n");
+- fprintf(stderr, "0 - append nothing\n");
+- fprintf(stderr, "1 - append quoted original message without attachments <default>\n\n");
++ fprintf(stderr, "0 - append nothing <default>\n");
++ fprintf(stderr, "1 - append quoted original message without attachments\n\n");
+ fprintf(stderr, "arsender - from address in generated message, or:\n\n");
+ fprintf(stderr, "+ = blank from envelope !\n");
+ fprintf(stderr, "$ = To: address will be used\n\n");
diff --git a/net-mail/autorespond/metadata.xml b/net-mail/autorespond/metadata.xml
new file mode 100644
index 000000000000..8c852c741509
--- /dev/null
+++ b/net-mail/autorespond/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>