summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/fetchmail/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/fetchmail/files')
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch14
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch11
-rw-r--r--net-mail/fetchmail/files/fetchmail.conf1
-rw-r--r--net-mail/fetchmail/files/fetchmail.confd10
-rw-r--r--net-mail/fetchmail/files/fetchmail.initd44
-rw-r--r--net-mail/fetchmail/files/fetchmail.service11
6 files changed, 91 insertions, 0 deletions
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch b/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch
new file mode 100644
index 000000000000..2eafe4dcbb24
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch
@@ -0,0 +1,14 @@
+--- fetchmail-6.3.26/Makefile.am
++++ fetchmail-6.3.26/Makefile.am
+@@ -16,9 +16,11 @@
+ pys= fetchmailconf.py
+ pym= fetchmailconf.man
+
++if HAVE_PYTHON
+ nodist_bin_SCRIPTS= fetchmailconf
+ python_PYTHON= $(pys)
+ dist_man1_MANS+= $(pym)
++endif
+
+ CLEANFILES= $(nodist_bin_SCRIPTS)
+
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch b/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch
new file mode 100644
index 000000000000..a0b3e8b5dfbb
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch
@@ -0,0 +1,11 @@
+--- fetchmail-6.3.26/Makefile.am
++++ fetchmail-6.3.26/Makefile.am
+@@ -45,7 +47,7 @@
+ check_PROGRAMS=
+
+ TESTS= t.smoke t.validate-xhtml10 t.validate-xhtml t.x509_name_match
+-TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)" $(SHELL)
++TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)"
+
+ if NEED_TRIO
+ noinst_LIBRARIES+= libtrio.a
diff --git a/net-mail/fetchmail/files/fetchmail.conf b/net-mail/fetchmail/files/fetchmail.conf
new file mode 100644
index 000000000000..07945f876468
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.conf
@@ -0,0 +1 @@
+d /run/fetchmail 700 fetchmail nobody
diff --git a/net-mail/fetchmail/files/fetchmail.confd b/net-mail/fetchmail/files/fetchmail.confd
new file mode 100644
index 000000000000..a5d0b74013b6
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.confd
@@ -0,0 +1,10 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Polling frequency in seconds
+# (fetchmail will daemonize and check for new mail at this interval)
+polling_period="60"
+
+# Directory where the pid file is kept
+pid_dir="/var/run/fetchmail"
diff --git a/net-mail/fetchmail/files/fetchmail.initd b/net-mail/fetchmail/files/fetchmail.initd
new file mode 100644
index 000000000000..889bcb61bb7d
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.initd
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+
+piddir=${pid_dir:-/var/run/fetchmail}
+pid_file=${piddir}/${RC_SVCNAME}.pid
+rcfile=/etc/${RC_SVCNAME}rc
+
+depend() {
+ need net
+ use mta
+}
+
+checkconfig() {
+ if [ ! -f ${rcfile} ]; then
+ eerror "Configuration file ${rcfile} not found"
+ return 1
+ fi
+ local fetchmail_instance
+ fetchmail_instance=${RC_SVCNAME##*.}
+ if [ -n "${fetchmail_instance}" -a "${RC_SVCNAME}" != "fetchmail" ]; then
+ fidfile=/var/lib/fetchmail/.fetchids.${RC_SVCNAME}
+ else
+ fidfile=/var/lib/fetchmail/.fetchids
+ fi
+ if [ ! -d ${piddir} ]; then
+ checkpath -q -d -o fetchmail:fetchmail -m 0755 ${piddir} || return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${RC_SVCNAME}"
+ start-stop-daemon --start --pidfile ${pid_file} \
+ --user fetchmail --exec /usr/bin/fetchmail \
+ -- -d ${polling_period} -f ${rcfile} \
+ --pidfile ${pid_file} -i ${fidfile}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${RC_SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile ${pid_file}
+ eend ${?}
+}
+
diff --git a/net-mail/fetchmail/files/fetchmail.service b/net-mail/fetchmail/files/fetchmail.service
new file mode 100644
index 000000000000..954f06e27be0
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A remote-mail retrieval utility
+After=network.target
+
+[Service]
+User=fetchmail
+ExecStart=/usr/bin/fetchmail -d 60 -f /etc/fetchmailrc
+RestartSec=1
+
+[Install]
+WantedBy=multi-user.target