summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:14:59 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:06 +0100
commitbbf4c7e032ea50a9ed3257fa3743abf2679c8485 (patch)
treef447145217a792f7bf4ee8e731d372b1555dd55f /net-mail/fetchmail
parentnet-im/spectrum2: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-bbf4c7e032ea50a9ed3257fa3743abf2679c8485.tar.gz
gentoo-bbf4c7e032ea50a9ed3257fa3743abf2679c8485.tar.bz2
gentoo-bbf4c7e032ea50a9ed3257fa3743abf2679c8485.zip
net-mail/fetchmail: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.19.ebuild2
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.20.ebuild2
-rw-r--r--net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-6.4.19.ebuild b/net-mail/fetchmail/fetchmail-6.4.19.ebuild
index dfd0275cfb0e..e2ab38dd186c 100644
--- a/net-mail/fetchmail/fetchmail-6.4.19.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.4.19.ebuild
@@ -98,6 +98,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Please see /etc/conf.d/fetchmail if you want to adjust"
elog "the polling delay used by the fetchmail init script."
diff --git a/net-mail/fetchmail/fetchmail-6.4.20.ebuild b/net-mail/fetchmail/fetchmail-6.4.20.ebuild
index 14870c0aa04a..3da9426438a4 100644
--- a/net-mail/fetchmail/fetchmail-6.4.20.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.4.20.ebuild
@@ -98,6 +98,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Please see /etc/conf.d/fetchmail if you want to adjust"
elog "the polling delay used by the fetchmail init script."
diff --git a/net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild b/net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild
index 2a9b14181a09..80f96706c304 100644
--- a/net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild
+++ b/net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild
@@ -101,6 +101,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Please see /etc/conf.d/fetchmail if you want to adjust"
elog "the polling delay used by the fetchmail init script."