summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-11-04 12:42:09 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-04 12:42:55 -0800
commitc8652c8212bf6e78e618401560035043ed11a8c3 (patch)
tree12c15cbaf4055fecca370ccfcd50097b4691a50f /net-misc/AQtion/AQtion-2.3.1.ebuild
parentnet-misc/chrony: stable 3.5-r2 for sparc, bug #698724 (diff)
downloadgentoo-c8652c8212bf6e78e618401560035043ed11a8c3.tar.gz
gentoo-c8652c8212bf6e78e618401560035043ed11a8c3.tar.bz2
gentoo-c8652c8212bf6e78e618401560035043ed11a8c3.zip
net-misc/AQtion: Version bump to 2.3.1
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-misc/AQtion/AQtion-2.3.1.ebuild')
-rw-r--r--net-misc/AQtion/AQtion-2.3.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/AQtion/AQtion-2.3.1.ebuild b/net-misc/AQtion/AQtion-2.3.1.ebuild
new file mode 100644
index 000000000000..6ea5a134c5c6
--- /dev/null
+++ b/net-misc/AQtion/AQtion-2.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+DESCRIPTION="Aquantia AQC multigigabit NIC linux driver (atlantic) - development preview"
+HOMEPAGE="https://github.com/Aquantia/AQtion"
+
+COMMIT_ID="3c2a2a3abe3df6cb0c985a49cea9a359a83e3f75"
+SRC_URI="https://github.com/Aquantia/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lro"
+
+DEPEND="virtual/linux-sources"
+
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+MODULE_NAMES="atlantic(drivers/net/ethernet/aquantia/atlantic:${S})"
+BUILD_TARGETS="all"
+CONFIG_CHECK="~!AQTION ~PTP_1588_CLOCK ~CRC_ITU_T"
+
+DOCS=(
+ README.md
+ README.txt
+)
+
+pkg_setup() {
+ use lro && CONFIG_CHECK+=" ~!CONFIG_BRIDGE"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use lro; then
+ sed -r -i -e 's/(#define AQ_CFG_IS_LRO_DEF[[:space:]]+)[[:digit:]]+([[:alpha:]]*)/\10\2/' \
+ aq_cfg.h || die
+ fi
+}
+
+src_compile() {
+ KDIR="${KERNEL_DIR}" linux-mod_src_compile
+}
+
+src_install() {
+ KDIR="${KERNEL_DIR}" linux-mod_src_install
+ dodoc "${DOCS[@]}"
+}