summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2016-09-27 15:29:37 +0100
committerTony Vroon <chainsaw@gentoo.org>2016-09-27 15:29:50 +0100
commitad1e96f8e90da81e63ddba381dddceb0a1cfd758 (patch)
treea36bc4f0ed2ed5db2e91096ba7e5007014e0f9bd /net-misc/bird/bird-1.6.1.ebuild
parentmedia-libs/opencv: revision bump to 3.1.0-r5 (diff)
downloadgentoo-ad1e96f8e90da81e63ddba381dddceb0a1cfd758.tar.gz
gentoo-ad1e96f8e90da81e63ddba381dddceb0a1cfd758.tar.bz2
gentoo-ad1e96f8e90da81e63ddba381dddceb0a1cfd758.zip
net-misc/bird: Version bump to 1.6.1 as requested by Moyaze Shivji in the LINX technology team.
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-misc/bird/bird-1.6.1.ebuild')
-rw-r--r--net-misc/bird/bird-1.6.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/bird/bird-1.6.1.ebuild b/net-misc/bird/bird-1.6.1.ebuild
new file mode 100644
index 000000000000..d6394ea93ef3
--- /dev/null
+++ b/net-misc/bird/bird-1.6.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_prepare() {
+ mkdir ipv6
+ tar c --exclude ipv6 . | tar x -C ipv6
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --disable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+
+ if use ipv6; then
+ cd ipv6
+ econf \
+ --enable-client \
+ --enable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+ fi
+}
+
+src_compile() {
+ emake
+ if use ipv6; then
+ cd ipv6
+ emake
+ fi
+}
+
+src_install() {
+ if use ipv6; then
+ newbin ipv6/birdc birdc6
+ newsbin ipv6/bird bird6
+ newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
+ fi
+ dobin birdc
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
+ dodoc doc/bird.conf.example
+}