summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-12-05 13:20:54 -0600
committerBen Kohler <bkohler@gentoo.org>2021-12-05 13:24:46 -0600
commita9a6608b17038ff300d026eaf3e346d51902cac3 (patch)
tree2ef983efcea3bb0dc726fc56fc84e27a26ae7418 /net-misc/cmst/cmst-2021.12.02.ebuild
parentsys-apps/yarn: stabilize 1.22.17 amd64 (diff)
downloadgentoo-a9a6608b17038ff300d026eaf3e346d51902cac3.tar.gz
gentoo-a9a6608b17038ff300d026eaf3e346d51902cac3.tar.bz2
gentoo-a9a6608b17038ff300d026eaf3e346d51902cac3.zip
net-misc/cmst: bump to 2021.12.02
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/cmst/cmst-2021.12.02.ebuild')
-rw-r--r--net-misc/cmst/cmst-2021.12.02.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/cmst/cmst-2021.12.02.ebuild b/net-misc/cmst/cmst-2021.12.02.ebuild
new file mode 100644
index 000000000000..88003e7ee218
--- /dev/null
+++ b/net-misc/cmst/cmst-2021.12.02.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt GUI for Connman with system tray icon"
+HOMEPAGE="https://github.com/andrew-bibb/cmst"
+SRC_URI="https://github.com/andrew-bibb/cmst/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ net-misc/connman
+"
+BDEPEND="dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+ export USE_LIBPATH="${EPREFIX}/usr/$(get_libdir)/${PN}"
+ eqmake5 DISTRO=gentoo
+}
+
+src_compile() {
+ lrelease cmst.pro
+ default
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ rm -r "${D}"/usr/share/licenses || die
+ gunzip "${D}"/usr/share/man/man1/cmst.1.gz
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}