summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-28 04:32:32 +0100
committerSam James <sam@gentoo.org>2022-04-28 04:32:32 +0100
commit0e5d1c23810cc4716ebafd7b2f2ecee276b424c3 (patch)
tree71b9bf5d3b4c539c9cab14edf0847407e6bd3dee /net-misc/dahdi-tools
parentmedia-libs/raspberrypi-userland: use udev.eclass; call udev_reload (diff)
downloadgentoo-0e5d1c23810cc4716ebafd7b2f2ecee276b424c3.tar.gz
gentoo-0e5d1c23810cc4716ebafd7b2f2ecee276b424c3.tar.bz2
gentoo-0e5d1c23810cc4716ebafd7b2f2ecee276b424c3.zip
net-misc/dahdi-tools: use udev.eclass; call udev_reload
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/dahdi-tools')
-rw-r--r--net-misc/dahdi-tools/dahdi-tools-3.1.0-r2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-misc/dahdi-tools/dahdi-tools-3.1.0-r2.ebuild b/net-misc/dahdi-tools/dahdi-tools-3.1.0-r2.ebuild
index 33e37114b885..49903c27e61a 100644
--- a/net-misc/dahdi-tools/dahdi-tools-3.1.0-r2.ebuild
+++ b/net-misc/dahdi-tools/dahdi-tools-3.1.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools bash-completion-r1 perl-functions
+inherit autotools bash-completion-r1 perl-functions udev
DESCRIPTION="Userspace tools to configure the kernel modules from net-misc/dahdi"
HOMEPAGE="https://www.asterisk.org"
@@ -47,7 +47,7 @@ src_install() {
local bashcompdir="$(get_bashcompdir)"
local bashcmd bashcmdtarget
- emake DESTDIR="${ED}" bashcompdir="${bashcompdir}" udevrulesdir=/lib/udev/rules.d install
+ emake DESTDIR="${ED}" bashcompdir="${bashcompdir}" udevrulesdir="$(get_udevdir)/rules.d" install
emake DESTDIR="${ED}" install-config
dosbin patgen pattest patlooptest hdlcstress hdlctest hdlcgen hdlcverify timertest
@@ -64,3 +64,7 @@ src_install() {
# Delete *if* the libtool file exists, bug #778380
find "${ED}" -name '*.la' -delete || die
}
+
+pkg_postinst() {
+ udev_reload
+}