summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-21 14:59:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-21 14:59:50 +0100
commite740ebc3aa18fe57db41182f24cc50f8845134ab (patch)
tree6f91f534535320efc13e7635e4353254021f31f3 /net-misc/htpdate/htpdate-1.1.3.ebuild
parentsys-cluster/mpich: bump 3.2 (diff)
downloadgentoo-e740ebc3aa18fe57db41182f24cc50f8845134ab.tar.gz
gentoo-e740ebc3aa18fe57db41182f24cc50f8845134ab.tar.bz2
gentoo-e740ebc3aa18fe57db41182f24cc50f8845134ab.zip
net-misc/htpdate: Bump to version 1.1.3
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/htpdate/htpdate-1.1.3.ebuild')
-rw-r--r--net-misc/htpdate/htpdate-1.1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/htpdate/htpdate-1.1.3.ebuild b/net-misc/htpdate/htpdate-1.1.3.ebuild
new file mode 100644
index 000000000000..d70048232eea
--- /dev/null
+++ b/net-misc/htpdate/htpdate-1.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo toolchain-funcs unpacker
+
+DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
+HOMEPAGE="http://www.vervest.org/fiki/bin/view/HTP/DownloadC"
+SRC_URI="http://www.vervest.org/htp/archive/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=""
+RDEPEND=""
+
+DOC_CONTENTS="If you would like to run htpdate as a daemon, set
+appropriate http servers in /etc/conf.d/htpdate!"
+
+src_prepare() {
+ # Use more standard adjtimex() to fix uClibc builds.
+ sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin htpdate
+ doman htpdate.8
+ dodoc README Changelog
+
+ newconfd "${FILESDIR}"/htpdate.conf htpdate
+ newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
+
+ readme.gentoo_create_doc
+}