summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-26 11:15:52 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-26 11:18:53 +0200
commit6380bed2339d97e9f3e74d75ce9de80d91f168a3 (patch)
tree6cb27a71e483d28322e67a34f9aa8e9c388a6d46 /net-misc/iperf/iperf-3.6.ebuild
parentapp-misc/uptimed: Bump to version 0.4.1 (diff)
downloadgentoo-6380bed2339d97e9f3e74d75ce9de80d91f168a3.tar.gz
gentoo-6380bed2339d97e9f3e74d75ce9de80d91f168a3.tar.bz2
gentoo-6380bed2339d97e9f3e74d75ce9de80d91f168a3.zip
net-misc/iperf: Versions 2.0.12 3.6.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc/iperf/iperf-3.6.ebuild')
-rw-r--r--net-misc/iperf/iperf-3.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-3.6.ebuild b/net-misc/iperf/iperf-3.6.ebuild
new file mode 100644
index 000000000000..3eb759c70f2d
--- /dev/null
+++ b/net-misc/iperf/iperf-3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="${HOMEPAGE}archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint"
+IUSE="sctp static-libs"
+
+DEPEND="sctp? ( net-misc/lksctp-tools )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_/}
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.5-flags.patch )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ use sctp || export ac_cv_header_netinet_sctp_h=no
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/iperf.confd iperf3
+ newinitd "${FILESDIR}"/iperf3.initd iperf3
+ prune_libtool_files
+}