summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-14 02:29:05 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-08-14 02:29:05 -0400
commit8d123fd111208e7c6dd1142dfd234e1902402471 (patch)
tree1c75366506fe81237263c60c4463c6ff3e2d7eea /net-misc/ipv6calc/ipv6calc-0.99.0.ebuild
parentsys-apps/rsbac-admin: version bump to 1.4.9. Remove older. (diff)
downloadgentoo-8d123fd111208e7c6dd1142dfd234e1902402471.tar.gz
gentoo-8d123fd111208e7c6dd1142dfd234e1902402471.tar.bz2
gentoo-8d123fd111208e7c6dd1142dfd234e1902402471.zip
net-misc/ipv6calc: version bump to 0.99.0.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-0.99.0.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.99.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-0.99.0.ebuild b/net-misc/ipv6calc/ipv6calc-0.99.0.ebuild
new file mode 100644
index 000000000000..526f6b80f208
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.99.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="geoip test"
+
+RDEPEND="
+ dev-libs/openssl:=
+ geoip? ( >=dev-libs/geoip-1.4.7 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Digest-SHA1 )
+"
+
+#dev-perl/URI is needed for web interface, that is not installed now
+
+src_configure() {
+ # These options are broken. You can't disable them. That's
+ # okay because we want then force enabled.
+ # --disable-db-as-registry
+ # --disable-db-cc-registry
+ if use geoip; then
+ myconf=$(use_enable geoip)
+ myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ fi
+ econf \
+ --disable-bundled-getopt \
+ --disable-bundled-md5 \
+ --enable-shared \
+ --enable-dynamic-load \
+ --enable-db-ieee \
+ --enable-db-ipv4 \
+ --enable-db-ipv6 \
+ --disable-dbip \
+ --disable-external \
+ --disable-ip2location \
+ ${myconf}
+}
+
+src_compile() {
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}