summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-12 11:02:27 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-12 11:03:24 +0100
commitcf7664dc40478c069e0e1b909fd341e4ee21ab7f (patch)
tree7a69ac0551bfe28cc2bc45c512afad03f27b8056 /net-misc/netopeer2
parentnet-misc/sysrepo: add 2.0.53 (diff)
downloadgentoo-cf7664dc40478c069e0e1b909fd341e4ee21ab7f.tar.gz
gentoo-cf7664dc40478c069e0e1b909fd341e4ee21ab7f.tar.bz2
gentoo-cf7664dc40478c069e0e1b909fd341e4ee21ab7f.zip
net-misc/netopeer2: add 2.0.35
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-misc/netopeer2')
-rw-r--r--net-misc/netopeer2/Manifest1
-rw-r--r--net-misc/netopeer2/netopeer2-2.0.35.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/netopeer2/Manifest b/net-misc/netopeer2/Manifest
index f05ba8239e90..0ec04065a386 100644
--- a/net-misc/netopeer2/Manifest
+++ b/net-misc/netopeer2/Manifest
@@ -1 +1,2 @@
DIST netopeer2-2.0.30.tar.gz 382529 BLAKE2B e17bc4eceb07b91347aac4e5167d7a92bfd7bfde77a79f27b6531f4ad0c77fc42e9281ed156b017969171dbb9f25e2570e9b2db1a85af9da896d5f39bd902555 SHA512 f0ec1b1e469b5a39ec4ae9533bc0cea6391068502defba3e3f25b154a573d37c030283b4483e27a11e8e372f580110af7df7279c6e1be3a2fec249a6b79c3d95
+DIST netopeer2-2.0.35.tar.gz 381321 BLAKE2B c776561b59bf05d093496e242fdb37766bf6292175186f92b85b86162d5fd6bba7118c41cef0ccfc835b09f34da1978f4e3aefb9961893b3d15b57117c3dbdb6 SHA512 f6b956c4b9d0f799f622eba62c2b20beb5f7db4899c6284bbb53303ff15f8787644687eeb99f1c68b455784166f2e858959ee16a345c0aabc444952bde70427d
diff --git a/net-misc/netopeer2/netopeer2-2.0.35.ebuild b/net-misc/netopeer2/netopeer2-2.0.35.ebuild
new file mode 100644
index 000000000000..04f0cbece36f
--- /dev/null
+++ b/net-misc/netopeer2/netopeer2-2.0.35.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Server for implementing NETCONF configuration management"
+HOMEPAGE="https://github.com/CESNET/netopeer2"
+SRC_URI="https://github.com/CESNET/netopeer2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:=
+ net-misc/curl:=
+ >=net-misc/sysrepo-2.0.53:=
+ >=net-libs/libnetconf2-2.0.24:=
+ net-libs/libssh:=
+ >=net-libs/libyang-2.0.112:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGENERATE_HOSTKEY=OFF
+ -DINSTALL_MODULES=OFF
+ -DMERGE_LISTEN_CONFIG=OFF
+ -DENABLE_TESTS=OFF
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/netopeer2
+ doins -r scripts/.
+}
+
+pkg_postinst() {
+ elog "In order to do initial server setup please"
+ elog "run setup scripts located in /etc/netopeer2"
+}