summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-12-30 14:48:17 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-12-30 14:57:27 +0100
commit138392a1abb7041dd9dd228c49c33c6daca4347a (patch)
treebbe4bf00c5cca95c0b1d96aaca69bb61282f2dd1 /net-misc/pyhoca-cli
parentnet-misc/python-x2go: 0.6.1.2 bump (diff)
downloadgentoo-138392a1abb7041dd9dd228c49c33c6daca4347a.tar.gz
gentoo-138392a1abb7041dd9dd228c49c33c6daca4347a.tar.bz2
gentoo-138392a1abb7041dd9dd228c49c33c6daca4347a.zip
net-misc/pyhoca-cli: 0.6.1.2 bump
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/pyhoca-cli')
-rw-r--r--net-misc/pyhoca-cli/Manifest1
-rw-r--r--net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/pyhoca-cli/Manifest b/net-misc/pyhoca-cli/Manifest
index a53deae0552e..a3ec62fbf9c1 100644
--- a/net-misc/pyhoca-cli/Manifest
+++ b/net-misc/pyhoca-cli/Manifest
@@ -1,2 +1,3 @@
DIST pyhoca-cli-0.6.0.1.tar.gz 40816 BLAKE2B 719ca6f277cfd2ecd2100e1b34e1c0d4d7e6849eb0b8f39d2a1628878b4da1bdcc1db622144d815347c33e0148d7fd6303caa661f146e18422169d7ae455c993 SHA512 65ced3bcb6e8fc15d22b0abc760a981af66b10325278613a9276de16c1e73d3b8d325b57aed9d4faf43a6d9eb8167045716c2974d4f6563c7a51df8ee66a69eb
DIST pyhoca-cli-0.6.1.1.tar.gz 41893 BLAKE2B 39f695224c64dacf0f2efa449ff3e235f22571647e77dd58ed031a0899991337af8deff5808293b4f1e1932a47dbd7af63ab6b86b1c5373122f4678eefec168a SHA512 b83e584f314df936d09cda25b253bbd5f37aa7f57db084424b2696070963a99776284c827f602321329bd066c6f483f32cd3dd0aa961eea7c79aa217949966c7
+DIST pyhoca-cli-0.6.1.2.tar.gz 41891 BLAKE2B a3183acc8b4a809e5b3894bbcb276972f3bf0178f2a9f596e697866db4217ca4e04d6b3d698b202e124a2e42a3b1f9b2f0fbd595bf0483f55dd7dbe9ea108ef3 SHA512 02bb6a0dcb72bc67e8b8109e554f04fa57d5b2da2682b50a081b60e19c257842ae31aabb7faa945579fb23d0e922befd0678c413b31393d368b4173e0d4315f6
diff --git a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
new file mode 100644
index 000000000000..30c368003023
--- /dev/null
+++ b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go command line client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+ find "${ED}" -name '*.pth' -delete || die
+}