summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-13 21:00:56 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-13 22:54:59 +0200
commitf5fb502e3018a92fdea1a4a019cf05669bb650a5 (patch)
treed4f3c6a33476cdde55355320bf793a9d8bc54a84 /net-misc/spread
parentacct-user/opendnssec: add user (151) opendnssec (diff)
downloadgentoo-f5fb502e3018a92fdea1a4a019cf05669bb650a5.tar.gz
gentoo-f5fb502e3018a92fdea1a4a019cf05669bb650a5.tar.bz2
gentoo-f5fb502e3018a92fdea1a4a019cf05669bb650a5.zip
net-misc/spread: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781434 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/spread')
-rw-r--r--net-misc/spread/spread-4.4.1-r1.ebuild32
-rw-r--r--net-misc/spread/spread-5.0.1-r1.ebuild32
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/spread/spread-4.4.1-r1.ebuild b/net-misc/spread/spread-4.4.1-r1.ebuild
new file mode 100644
index 000000000000..70da45c67ba2
--- /dev/null
+++ b/net-misc/spread/spread-4.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="spread-src"
+
+DESCRIPTION="Distributed network messaging system"
+HOMEPAGE="http://www.spread.org"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Spread-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ acct-group/spread
+ acct-user/spread
+"
+
+src_prepare() {
+ default
+
+ # don't strip binaries
+ sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+}
diff --git a/net-misc/spread/spread-5.0.1-r1.ebuild b/net-misc/spread/spread-5.0.1-r1.ebuild
new file mode 100644
index 000000000000..85b0f141896f
--- /dev/null
+++ b/net-misc/spread/spread-5.0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="spread-src"
+
+DESCRIPTION="Distributed network messaging system"
+HOMEPAGE="http://www.spread.org"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Spread-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/spread
+ acct-user/spread
+"
+
+src_prepare() {
+ default
+
+ # don't strip binaries
+ sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+}