summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-24 00:39:23 +0100
committerSam James <sam@gentoo.org>2023-07-24 00:39:46 +0100
commit9320ad28319122fa54745533724a793be777d3d3 (patch)
tree463f199b06c353107e12f9dbdbc1edc35fb77347 /net-misc/streamlink
parentdev-util/diffoscope: add 245 (diff)
downloadgentoo-9320ad28319122fa54745533724a793be777d3d3.tar.gz
gentoo-9320ad28319122fa54745533724a793be777d3d3.tar.bz2
gentoo-9320ad28319122fa54745533724a793be777d3d3.zip
net-misc/streamlink: add 6.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-6.0.0.ebuild61
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild9
3 files changed, 68 insertions, 3 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index c1e57152edb1..27912aff3dce 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1 +1,2 @@
DIST streamlink-5.5.1.tar.gz 536064 BLAKE2B 0a651c5dcf9fe0a70ee93505ad0a0ea6aaf10739edc763a796633ce34b8235e4aa6a5a45bd1f6dd2591ced9cd87141d4b89d34e9e399d6166d74c9c3ee12f5ea SHA512 2d7fd75bbf356baaf91791930e74e361b37abf0ff1251fa3022ca216dc16a8610635089cb746506baec82c31f8bc569e3b8e538b17ba910389168e61dcdbbe0f
+DIST streamlink-6.0.0.tar.gz 681437 BLAKE2B 32d8e334fd88efddf0532d459352d9a66276a69020d7be30632772636085e67b8dfc70606c9d5fb8b7ff14185c41774b4caa1a5a6b7dbbc698d4931739aeff1e SHA512 6726cfc5c4cb1572e2e476ec097db6edaace2516efb9e01c52498cfac8cc3f319b9aa4475f6726f7b9a0a15ddc0a8a3de37e1cadc995acbfaba6a8e198051e2c
diff --git a/net-misc/streamlink/streamlink-6.0.0.ebuild b/net-misc/streamlink/streamlink-6.0.0.ebuild
new file mode 100644
index 000000000000..7d0a43ab5bbb
--- /dev/null
+++ b/net-misc/streamlink/streamlink-6.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+distutils_enable_tests pytest
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 6c6140e9a8da..7d0a43ab5bbb 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="BSD-2 Apache-2.0"
@@ -28,13 +28,15 @@ SLOT="0"
DEPEND="
$(python_gen_cond_dep '
dev-python/certifi[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
')
@@ -50,6 +52,7 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
)
')