summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-09-09 22:54:14 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-09-09 22:54:14 +0100
commit9450fa1b30af7f79bd1b5354230e79d12ef84268 (patch)
tree70b9d8d21ad2c8cadca373a389b62488adbfa086 /net-misc/sunshine
parentkde-misc/krename: add 5.0.60_pre20240906 (diff)
downloadgentoo-9450fa1b30af7f79bd1b5354230e79d12ef84268.tar.gz
gentoo-9450fa1b30af7f79bd1b5354230e79d12ef84268.tar.bz2
gentoo-9450fa1b30af7f79bd1b5354230e79d12ef84268.zip
net-misc/sunshine: Fix 9999 build by disabling docs
Building the docs involves more npm pain. It's not worth it. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-misc/sunshine')
-rw-r--r--net-misc/sunshine/sunshine-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-misc/sunshine/sunshine-9999.ebuild b/net-misc/sunshine/sunshine-9999.ebuild
index 6135d7c43f78..5018392b1133 100644
--- a/net-misc/sunshine/sunshine-9999.ebuild
+++ b/net-misc/sunshine/sunshine-9999.ebuild
@@ -52,7 +52,7 @@ DESCRIPTION="Self-hosted game stream host for Moonlight"
HOMEPAGE="https://github.com/LizardByte/Sunshine"
LICENSE="GPL-3"
SLOT="0"
-IUSE="cuda debug libdrm svt-av1 trayicon vaapi wayland X x264 x265"
+IUSE="cuda debug libdrm svt-av1 systemd trayicon vaapi wayland X x264 x265"
# Strings for CPU features in the useflag[:configure_option] form
# if :configure_option isn't set, it will use 'useflag' as configure option
@@ -338,6 +338,7 @@ src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=no
-DBOOST_USE_STATIC=no
+ -DBUILD_DOCS=no
-DBUILD_TESTS=no
-DCCACHE_FOUND=no
-DCMAKE_DISABLE_FIND_PACKAGE_Git=yes
@@ -352,9 +353,9 @@ src_configure() {
-DSUNSHINE_ENABLE_TRAY=$(usex trayicon)
-DSUNSHINE_REQUIRE_TRAY=$(usex trayicon)
-DSUNSHINE_SYSTEM_WAYLAND_PROTOCOLS=yes
- -DSYSTEMD_USER_UNIT_INSTALL_DIR=$(systemd_get_userunitdir)
-DUDEV_RULES_INSTALL_DIR=$(get_udevdir)/rules.d
)
+ use systemd && mycmakeargs+=( -DSYSTEMD_USER_UNIT_INSTALL_DIR=$(systemd_get_userunitdir) )
[[ ${PV} = 9999* ]] || mycmakeargs+=( -DNPM="${BROOT}"/bin/true )
CMAKE_USE_DIR="${S}" cmake_src_configure
}