summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-12-05 23:57:32 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-12-05 23:57:32 +0100
commita5f0828071648bd1510b17ea044cc3df0072e5a8 (patch)
treef6cf9dc7444eb68e77cff0f7907388f3a05dad4c /net-misc/uftp/uftp-4.9.8.ebuild
parentdev-python/python-iptables: Version bump to 0.13.0 (diff)
downloadgentoo-a5f0828071648bd1510b17ea044cc3df0072e5a8.tar.gz
gentoo-a5f0828071648bd1510b17ea044cc3df0072e5a8.tar.bz2
gentoo-a5f0828071648bd1510b17ea044cc3df0072e5a8.zip
net-misc/uftp: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-misc/uftp/uftp-4.9.8.ebuild')
-rw-r--r--net-misc/uftp/uftp-4.9.8.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/uftp/uftp-4.9.8.ebuild b/net-misc/uftp/uftp-4.9.8.ebuild
new file mode 100644
index 000000000000..08943133b714
--- /dev/null
+++ b/net-misc/uftp/uftp-4.9.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Encrypted UDP based FTP with multicast"
+HOMEPAGE="http://uftp-multicast.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}-multicast/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+server ssl"
+
+# openssl with EC required, see #644674
+DEPEND="ssl? ( dev-libs/openssl:0=[-bindist] )"
+RDEPEND="${DEPEND}"
+
+# Workaround, see #644670
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.9.4_makefile.patch"
+)
+
+src_compile() {
+ use ssl || local opt="NO_ENCRYPTION=1"
+ emake CC=$(tc-getCC) $opt uftp uftp_keymgt
+ use server && emake CC=$(tc-getCC) $opt uftpd uftpproxyd
+}
+
+src_install() {
+ dobin uftp uftp_keymgt
+ dodoc {Changes,protocol,ReadMe}.txt
+ doman uftp.1 uftp_keymgt.1
+
+ if use server ; then
+ dosbin uftpd uftpproxyd
+ newinitd "${FILESDIR}/uftpd.init" uftpd
+ newconfd "${FILESDIR}/uftpd.conf" uftpd
+ newinitd "${FILESDIR}/uftpproxyd.init" uftpproxyd
+ newconfd "${FILESDIR}/uftpproxyd.conf" uftpproxyd
+ doman uftpd.1 uftpproxyd.1
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" uftpd
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn "Please note, uftpd 4.x server is not backward compatible with"
+ ewarn "uftp 3.x clients! Please upgrade clients before servers."
+ fi
+}