summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-14 01:11:29 +0100
committerSam James <sam@gentoo.org>2023-05-14 01:31:19 +0100
commit399f991eaabbe8a6c26d3658016e33150b576149 (patch)
tree03f35f7143e40e63e803eae21dd1ba2313d7ea9a /net-misc/wget2
parentsys-apps/dbus: add Valgrind annotation support (diff)
downloadgentoo-399f991eaabbe8a6c26d3658016e33150b576149.tar.gz
gentoo-399f991eaabbe8a6c26d3658016e33150b576149.tar.bz2
gentoo-399f991eaabbe8a6c26d3658016e33150b576149.zip
net-misc/wget2: drop invalid USE=valgrind flag (for test suite)
We don't, in general, run Valgrind for test suites in Gentoo because it's not portable enough and gives inconsistent results, especially under sandbox. Plus it's confusing given USE=valgrind is effectively a global USE flag (even if it isn't in use.desc yet) for meaning "enable annotations to enable better debugging under Valgrind", rather than "run tests under it". Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/wget2')
-rw-r--r--net-misc/wget2/metadata.xml1
-rw-r--r--net-misc/wget2/wget2-2.0.1-r2.ebuild8
-rw-r--r--net-misc/wget2/wget2-2.0.1.ebuild8
-rw-r--r--net-misc/wget2/wget2-9999.ebuild8
4 files changed, 9 insertions, 16 deletions
diff --git a/net-misc/wget2/metadata.xml b/net-misc/wget2/metadata.xml
index b9d9ab8fa92e..0143e665405e 100644
--- a/net-misc/wget2/metadata.xml
+++ b/net-misc/wget2/metadata.xml
@@ -12,6 +12,5 @@
<flag name="lzip">Enable <pkg>app-arch/lzip</pkg> support via <pkg>app-arch/lzlib</pkg></flag>
<flag name="openssl">Enable crypto support via <pkg>dev-libs/openssl</pkg></flag>
<flag name="psl">Use public suffix list via <pkg>net-libs/libpsl</pkg></flag>
- <flag name="valgrind">Depend on <pkg>dev-util/valgrind</pkg> for test suite</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/wget2/wget2-2.0.1-r2.ebuild b/net-misc/wget2/wget2-2.0.1-r2.ebuild
index 1e0c733d2a3d..c9f6bad3566c 100644
--- a/net-misc/wget2/wget2-2.0.1-r2.ebuild
+++ b/net-misc/wget2/wget2-2.0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,8 +12,7 @@ LICENSE="GPL-3+ LGPL-3+"
SLOT="0/0" # subslot = libwget.so version
QA_PKGCONFIG_VERSION="2.1.0" # libwget pkg-config versioning
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test valgrind xattr zlib"
-REQUIRED_USE="valgrind? ( test )"
+IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test xattr zlib"
RDEPEND="
brotli? ( app-arch/brotli )
@@ -43,7 +42,6 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen[dot] )
- valgrind? ( dev-util/valgrind )
"
RESTRICT="!test? ( test )"
@@ -51,12 +49,12 @@ RESTRICT="!test? ( test )"
src_configure() {
local myeconfargs=(
--disable-static
+ --disable-valgrind-tests
--with-plugin-support
--with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
--without-libidn
--without-libmicrohttpd
$(use_enable doc)
- $(use_enable valgrind valgrind-tests)
$(use_enable xattr)
$(use_with brotli brotlidec)
$(use_with bzip2)
diff --git a/net-misc/wget2/wget2-2.0.1.ebuild b/net-misc/wget2/wget2-2.0.1.ebuild
index 93ecce3e0724..974ef7241035 100644
--- a/net-misc/wget2/wget2-2.0.1.ebuild
+++ b/net-misc/wget2/wget2-2.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,8 +15,7 @@ fi
# LGPL for libwget
LICENSE="GPL-3+ LGPL-3+"
SLOT="0/0" # subslot = libwget.so version
-IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test valgrind xattr zlib"
-REQUIRED_USE="valgrind? ( test )"
+IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test xattr zlib"
RDEPEND="
brotli? ( app-arch/brotli )
@@ -46,7 +45,6 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
- valgrind? ( dev-util/valgrind )
"
RESTRICT="!test? ( test )"
@@ -84,12 +82,12 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--disable-static
+ --disable-valgrind-tests
--with-plugin-support
--with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
--without-libidn
--without-libmicrohttpd
$(use_enable doc)
- $(use_enable valgrind valgrind-tests)
$(use_enable xattr)
$(use_with brotli brotlidec)
$(use_with bzip2)
diff --git a/net-misc/wget2/wget2-9999.ebuild b/net-misc/wget2/wget2-9999.ebuild
index a5d97827fcb9..2d271b4a835e 100644
--- a/net-misc/wget2/wget2-9999.ebuild
+++ b/net-misc/wget2/wget2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,8 +13,7 @@ EGIT_REPO_URI="https://gitlab.com/gnuwget/wget2.git"
LICENSE="GPL-3+ LGPL-3+"
SLOT="0/0" # subslot = libwget.so version
KEYWORDS=""
-IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test valgrind xattr zlib"
-REQUIRED_USE="valgrind? ( test )"
+IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test xattr zlib"
RDEPEND="
brotli? ( app-arch/brotli )
@@ -44,7 +43,6 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen[dot] )
- valgrind? ( dev-util/valgrind )
"
RESTRICT="!test? ( test )"
@@ -77,12 +75,12 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--disable-static
+ --disable-valgrind-tests
--with-plugin-support
--with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
--without-libidn
--without-libmicrohttpd
$(use_enable doc)
- $(use_enable valgrind valgrind-tests)
$(use_enable xattr)
$(use_with brotli brotlidec)
$(use_with bzip2)