summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2025-01-15 19:06:08 -0500
committerIonen Wolkens <ionen@gentoo.org>2025-01-15 19:08:23 -0500
commit56e4062f796ecc0a57bc59a31d5fb2203c191e95 (patch)
treedc0b947c16cb8dbc57b30688f4d1a8b4eafdc05c /net-misc
parentRevert "sys-apps/systemd: drop hwids blocker" (diff)
downloadgentoo-56e4062f796ecc0a57bc59a31d5fb2203c191e95.tar.gz
gentoo-56e4062f796ecc0a57bc59a31d5fb2203c191e95.tar.bz2
gentoo-56e4062f796ecc0a57bc59a31d5fb2203c191e95.zip
net-misc/yt-dlp: add 2025.01.15
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2025.01.15.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 2940dbf347aa..32c690817381 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,2 +1,3 @@
DIST yt-dlp-2024.12.23.tar.gz 5817118 BLAKE2B 99df0c13661d5768bb38545d59ba982365ca62a26c90f7217793b9a386ad932164e4e166c20cb05449cf56950324a56ee3aea56a2fb1fa5258dc8e0872e2e784 SHA512 8b068ebb88fc7339f685dfe999a1814f43098c16bd89033154f872e53e6743090c210ac5cb5cdd783ebd947ac33ecb749b08bbec9c7d7dc41da3424968666ee8
DIST yt-dlp-2025.01.12.tar.gz 5821087 BLAKE2B 8d385e4aeed026f1c85f06b7a7bb1403f9561852f49cca51030c6fd88bcd66462e56de2419eff2fd784091cc87431e14a6ab5abc1ebd23f8b9d05d7d9f667ed1 SHA512 bea91c322ac33a717deff7558cae7d12e1337e3a9888860a339c6315dca08814b4ef1018848adf3c434aaacdf093e96a6e5ad07e60bd76b1f8abf6cb7f1b418b
+DIST yt-dlp-2025.01.15.tar.gz 5819696 BLAKE2B f846d9bc7dec85667dc6ded40b9307731889fe1736920a40367de8f3ec3b1127f630d437792654baf21a2d83a3cd59757341cb6fbfe95f4b614e650d061c231d SHA512 20786cb0d16e58dc9fb2b2e35852b496862d79dfa42ebf92e430161c89863fc1d6247a2c1f9220e8555b20ea60ffbabb3e0d81521df98e47677f56ad1f4a68a1
diff --git a/net-misc/yt-dlp/yt-dlp-2025.01.15.ebuild b/net-misc/yt-dlp/yt-dlp-2025.01.15.ebuild
new file mode 100644
index 000000000000..213369c3ecb0
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2025.01.15.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}