summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-02-02 18:13:35 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-28 09:01:47 +0200
commitd0be1841c349cb0e132483f3448fb02e4479aa8c (patch)
treeefed6103f6e812e521dc37be8578841a26f61788 /net-misc
parentnet-misc/tinyssh: respect user CFLAGS (diff)
downloadgentoo-d0be1841c349cb0e132483f3448fb02e4479aa8c.tar.gz
gentoo-d0be1841c349cb0e132483f3448fb02e4479aa8c.tar.bz2
gentoo-d0be1841c349cb0e132483f3448fb02e4479aa8c.zip
net-misc/tinyssh: C99 compatibility
Closes: https://bugs.gentoo.org/923493 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/35150 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tinyssh/files/tinyssh-20240101_c99.patch33
-rw-r--r--net-misc/tinyssh/tinyssh-20240101.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/tinyssh/files/tinyssh-20240101_c99.patch b/net-misc/tinyssh/files/tinyssh-20240101_c99.patch
new file mode 100644
index 000000000000..38b2e845eaa5
--- /dev/null
+++ b/net-misc/tinyssh/files/tinyssh-20240101_c99.patch
@@ -0,0 +1,33 @@
+From ae059fda00c11236a32499f105e803f962d1e243 Mon Sep 17 00:00:00 2001
+From: "Haelwenn (lanodan) Monnier" <contact@hacktivis.me>
+Date: Tue, 9 Jan 2024 19:51:14 +0100
+Subject: [PATCH] packet_put: Add missing bug.h include for global_die
+
+```
+packet_put.c:53:9: error: call to undeclared function 'global_die'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
+ global_die(111);
+ ^
+1 error generated.
+```
+
+Upstream: https://github.com/janmojzis/tinyssh/pull/84
+
+---
+ tinyssh/packet_put.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tinyssh/packet_put.c b/tinyssh/packet_put.c
+index 17e8d84..7f46ff6 100644
+--- a/tinyssh/packet_put.c
++++ b/tinyssh/packet_put.c
+@@ -6,6 +6,7 @@ Public domain.
+
+ #include "uint32_pack_big.h"
+ #include "buf.h"
++#include "bug.h"
+ #include "sshcrypto.h"
+ #include "ssh.h"
+ #include "log.h"
+--
+2.41.0
+
diff --git a/net-misc/tinyssh/tinyssh-20240101.ebuild b/net-misc/tinyssh/tinyssh-20240101.ebuild
index 0edea200702b..442fb8e5f171 100644
--- a/net-misc/tinyssh/tinyssh-20240101.ebuild
+++ b/net-misc/tinyssh/tinyssh-20240101.ebuild
@@ -29,6 +29,7 @@ RDEPEND="
"
PATCHES=(
+ "${FILESDIR}/tinyssh-20240101_c99.patch"
"${FILESDIR}/tinyssh-20240101_conf_cflags.patch"
)