summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-14 11:20:53 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-14 11:32:14 +0200
commit4d5acb3477a4b209d4a9cb45a58639e27417ff27 (patch)
tree1fa2e3eb840f21ae55e92fe5c6749ff144bd4c6f /net-p2p
parentnet-p2p/transmission-remote-gtk: take maintainership (diff)
downloadgentoo-4d5acb3477a4b209d4a9cb45a58639e27417ff27.tar.gz
gentoo-4d5acb3477a4b209d4a9cb45a58639e27417ff27.tar.bz2
gentoo-4d5acb3477a4b209d4a9cb45a58639e27417ff27.zip
net-p2p/transmission-remote-gtk: bump to 1.4.1
Closes: https://bugs.gentoo.org/677692 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-remote-gtk/Manifest1
-rw-r--r--net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.4.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/transmission-remote-gtk/Manifest b/net-p2p/transmission-remote-gtk/Manifest
index f6a6f630b59e..2205e2f9f340 100644
--- a/net-p2p/transmission-remote-gtk/Manifest
+++ b/net-p2p/transmission-remote-gtk/Manifest
@@ -1 +1,2 @@
DIST transmission-remote-gtk-1.3.1.tar.xz 459260 BLAKE2B 3e1e184ce6fe0698996763419e5d8b1fc187d7c17ba42e9d75463d6b772bdde554fc1d4b6da6f19a936762b315caa0cea64c47e587d10c592402fb87a518cf66 SHA512 ce723d51f8f769e59fb539241996ff0204a654f52696963044f8535731cc2b8ec69cf454a15253f9ba214e0879498f3c19519b5b1b303273d667592887ee45f5
+DIST transmission-remote-gtk-1.4.1.tar.xz 543620 BLAKE2B dea556138a7f554a6cbe5c3e0d5bdd9057cb61d2d80e2d89beb96b2926218e19ce85759fd079375ba8896e185bbdec74979372a9413dc5c513204f47b93e4304 SHA512 c1a2c26d01bc2557bafae9baa370f713e0412ac8445e12b19e9b3027c1a269745dbb865195d683af397d43a2956f51aad8bdfcaff93e4f07015e33715770de48
diff --git a/net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.4.1.ebuild b/net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.4.1.ebuild
new file mode 100644
index 000000000000..4e12624edbb7
--- /dev/null
+++ b/net-p2p/transmission-remote-gtk/transmission-remote-gtk-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="GTK+ client for management of the Transmission BitTorrent client, over HTTP RPC"
+HOMEPAGE="https://github.com/transmission-remote-gtk/transmission-remote-gtk"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ayatana debug geoip libnotify libproxy rss"
+
+# RESTRICT="test"
+
+# FIXME: bundles rss-glib-0.2.3
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.12.6
+ net-misc/curl
+ >=x11-libs/gtk+-3.16:3
+ ayatana? ( dev-libs/libappindicator:3 )
+ geoip? ( dev-libs/geoip )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ libproxy? ( net-libs/libproxy )
+ rss? ( >=net-libs/libmrss-0.18 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+" # eautoreconf needs sys-devel/autoconf-archive
+
+src_configure() {
+ # Disable overly strict appdata validation
+ gnome2_src_configure \
+ $(use_enable debug) \
+ $(use_with geoip libgeoip) \
+ $(use_with libnotify) \
+ $(use_with libproxy) \
+ $(use_with ayatana libappindicator) \
+ $(use_with rss libmrss) \
+ APPSTREAM_UTIL="$(type -P true)"
+}