summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-03-31 19:57:49 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-03-31 19:57:49 +0200
commitb53276a9e590f5b87561352b4407b7038b2e1bb5 (patch)
tree4379a3f343daff66dc062550383fff24905b0c62 /net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
parentnet-print/foomatic-db: Update snapshot (diff)
downloadgentoo-b53276a9e590f5b87561352b4407b7038b2e1bb5.tar.gz
gentoo-b53276a9e590f5b87561352b4407b7038b2e1bb5.tar.bz2
gentoo-b53276a9e590f5b87561352b4407b7038b2e1bb5.zip
net-print/foomatic-db-ppds: Update snapshot
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild')
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
new file mode 100644
index 000000000000..0882c8398521
--- /dev/null
+++ b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_P=${PN/-ppds}-$(replace_version_separator 2 '-')
+
+DESCRIPTION="linuxprinting.org PPD files for postscript printers"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ epatch "${FILESDIR}/Makefile.in-4.0.20120117.patch"
+ rm db/source/PPD/Kyocera/ReadMe.htm || die # bug #559008
+}
+
+src_install() {
+ default
+ rm -v "${ED}"/usr/share/foomatic/xmlschema/{driver,option,printer,types}.xsd || die "Cannot remove duplicates"
+}