summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2021-03-25 10:35:28 +0200
committerSam James <sam@gentoo.org>2021-03-29 15:36:19 +0000
commit80e91505d262c7c2d1edfc6f54fafa6ac109ceff (patch)
tree76770ef2e57e19148e78e6bc15ec471d93c2651b /net-voip/sipvicious
parentapp-i18n/man-pages-l10n: Stabilize 4.2.0-r1 ALLARCHES, #779067 (diff)
downloadgentoo-80e91505d262c7c2d1edfc6f54fafa6ac109ceff.tar.gz
gentoo-80e91505d262c7c2d1edfc6f54fafa6ac109ceff.tar.bz2
gentoo-80e91505d262c7c2d1edfc6f54fafa6ac109ceff.zip
net-voip/sipvicious: Version 0.3.3
Sneak in p-m addition to maintainers in metadata.xml. Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/20111 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-voip/sipvicious')
-rw-r--r--net-voip/sipvicious/Manifest1
-rw-r--r--net-voip/sipvicious/metadata.xml4
-rw-r--r--net-voip/sipvicious/sipvicious-0.3.3.ebuild31
3 files changed, 36 insertions, 0 deletions
diff --git a/net-voip/sipvicious/Manifest b/net-voip/sipvicious/Manifest
index 31115c2a9f19..1f7def0b3068 100644
--- a/net-voip/sipvicious/Manifest
+++ b/net-voip/sipvicious/Manifest
@@ -1 +1,2 @@
DIST sipvicious-0.3.0.tar.gz 43097 BLAKE2B 5ddcdf775db0ade6e61e77009c7991d8523db02dbdd6e8588c23f5cd6f4d2868dd1d78e7f17322cde67414b4eb2b8c89f2d4ee0079487e5f5f7ee75f4759adf5 SHA512 35aa3ea7d3cfd6f84716cd95a263357881196eaa180375d1f0a392a1478292ba9a8bf6cd53888448523f7faa447c82cc43fb1ef6c105a0e93e6c7854a51da172
+DIST sipvicious-0.3.3.tar.gz 46217 BLAKE2B 4ef872ecea9113f3ec24df98133230f678ccfff24380c2fafff810a4cbc3e2fe26866deb3595a7540cd42d34fd5bc045e6a2f51c7eb6403a445f33acd74e2213 SHA512 d1bcfdc62054d7b8188c35f7b1d14284b1f66e5501e40747819a79d578677b724ce0d38b28b497c7afa390c6d46fd410749408109ec4e08ba0adfde53b5b79bc
diff --git a/net-voip/sipvicious/metadata.xml b/net-voip/sipvicious/metadata.xml
index 247a5130944c..a9b28a07f457 100644
--- a/net-voip/sipvicious/metadata.xml
+++ b/net-voip/sipvicious/metadata.xml
@@ -9,5 +9,9 @@
<email>sam@gentoo.org</email>
<name>Sam James</name>
</maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<stabilize-allarches/>
</pkgmetadata>
diff --git a/net-voip/sipvicious/sipvicious-0.3.3.ebuild b/net-voip/sipvicious/sipvicious-0.3.3.ebuild
new file mode 100644
index 000000000000..d9ee3d1d686d
--- /dev/null
+++ b/net-voip/sipvicious/sipvicious-0.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="SIPVicious is a SIP security package"
+HOMEPAGE="https://github.com/EnableSecurity/sipvicious/wiki"
+SRC_URI="https://github.com/EnableSecurity/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare()
+{
+ default
+ sed -re 's:man/man1:share/man/man1:' -i setup.py || die "Error updating man page installation location."
+}