summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetru Ciobanu <scantlight@gmail.com>2021-10-12 22:51:41 -0700
committerSam James <sam@gentoo.org>2021-10-20 03:26:10 +0000
commit3f1bd768f4eced00e6854d5bb4d1486933c30cb2 (patch)
tree86048ef4f8ffaa62ca4a25cfa4e089e75b8483cd /net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild
parentnet-vpn/openfortivpn: Version bump 1.17.0 (diff)
downloadgentoo-3f1bd768f4eced00e6854d5bb4d1486933c30cb2.tar.gz
gentoo-3f1bd768f4eced00e6854d5bb4d1486933c30cb2.tar.bz2
gentoo-3f1bd768f4eced00e6854d5bb4d1486933c30cb2.zip
net-vpn/openfortivpn: Version bump 1.17.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Petru Ciobanu <scantlight@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild')
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild b/net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild
new file mode 100644
index 000000000000..0c64cdfd137f
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.17.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ net-dialup/ppp
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}